[MapProxy] Error starting the test server

Andrew Smith asmith at mapaction.org
Wed Aug 29 07:51:41 PDT 2012

Benjamin, thank you for your reply. 

I've tried various combinations on this using both the eth0 and loopback ip addresses for the bind param, with or without the port 8080 


I get the same error with any of these. Do you have any other suggestions? 

Many thanks, 

----- Original Message -----

From: "Benjamin Wragg" <bwragg at isasolutions.com.au> 
To: "Andrew Smith" <asmith at mapaction.org> 
Cc: mapproxy at lists.osgeo.org 
Sent: Wednesday, 29 August, 2012 2:30:26 PM 
Subject: Re: [MapProxy] Error starting the test server 

Hi Andrew, isn't a valid ip address. You need to enter the ip address of the machine your running this on. 



On 29/08/2012, at 10:26 PM, Andrew Smith < asmith at mapaction.org > wrote: 


I've tried setting up MapProxy 1.4 on my laptop (Ubuntu 11.04 x86_64) using the instructions here; http://mapproxy.org/docs/latest/install.html 
However I'm unable to start the test server with this error occuring: 

andy at shaun:~/mymapproxy$ sudo mapproxy-util serve-develop ./mapproxy.yaml -b 
[2012-08-29 11:32:53,555] mapproxy.config - INFO - reading: /home/andy/mymapproxy/mapproxy.yaml 
Traceback (most recent call last): 
File "/usr/local/bin/mapproxy-util", line 9, in <module> 
load_entry_point('MapProxy==1.4.0', 'console_scripts', 'mapproxy-util')() 
File "/usr/local/lib/python2.7/dist-packages/MapProxy-1.4.0-py2.7.egg/mapproxy/script/util.py", line 319, in main 
File "/usr/local/lib/python2.7/dist-packages/MapProxy-1.4.0-py2.7.egg/mapproxy/script/util.py", line 72, in serve_develop_command 
app = make_wsgi_app(mapproxy_conf, debug=options.debug) 
File "/usr/local/lib/python2.7/dist-packages/MapProxy-1.4.0-py2.7.egg/mapproxy/wsgiapp.py", line 91, in make_wsgi_app 
conf = load_configuration(mapproxy_conf=services_conf, ignore_warnings=ignore_config_warnings) 
File "/usr/local/lib/python2.7/dist-packages/MapProxy-1.4.0-py2.7.egg/mapproxy/config/loader.py", line 1276, in load_configuration 
conf_dict = load_configuration_file([os.path.basename(mapproxy_conf)], conf_base_dir) 
File "/usr/local/lib/python2.7/dist-packages/MapProxy-1.4.0-py2.7.egg/mapproxy/config/loader.py", line 1294, in load_configuration_file 
current_dict = load_yaml_file(conf_file) 
File "/usr/local/lib/python2.7/dist-packages/MapProxy-1.4.0-py2.7.egg/mapproxy/util/yaml.py", line 29, in load_yaml_file 
return load_yaml(f) 
File "/usr/local/lib/python2.7/dist-packages/MapProxy-1.4.0-py2.7.egg/mapproxy/util/yaml.py", line 38, in load_yaml 
return yaml.load(doc, Loader=yaml.CLoader) 
File "/usr/local/lib/python2.7/dist-packages/PyYAML-3.10-py2.7-linux-x86_64.egg/yaml/__init__.py", line 73, in load 
AttributeError: 'CLoader' object has no attribute 'dispose' 

andy at shaun:~/mymapproxy$ uname -a 
Linux shaun 2.6.38-15-generic #65-Ubuntu SMP Thu Jul 26 20:13:19 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux 

I've tried the same using the actual IP address of the laptop but with the same result. 

I'd be very grateful if anyone could point me in the right direction on this. 
Many thanks, 

MapProxy mailing list 
MapProxy at lists.osgeo.org 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/mapproxy/attachments/20120829/60cf1387/attachment.html>

More information about the MapProxy mailing list