[MapProxy] Merged Tiles- Differences Between Versions

Jeremy Holt jholt at adc4gis.com
Thu Jul 11 08:25:48 PDT 2013

Hi List,
Thanks for your time; I'm hoping I can get some direction on this issue.

Previously, using Mapproxy version 0.8, I was able to make a WMS request
that contained 2 layers from separate caches (one vector/png, one
aerial/jpeg) as FORMAT=image/JPEG and the response tile would be merged. A
single jpeg tile with the vectors transparent on top of the imagery.
Here is an example of that request:

After transitioning to version 1.5 it appears that I'm not able to make
these same types of requests. Basically, I get an invalid tile format
error. Here is that example (throws service error):

Note that the WMS requests are the same parameters (albeit different
sources), and if you change the format type to PNG, it will respond with
only the vector layer and not the aerial.

When bumping up the yamls for comparison, I haven't been able to locate any
glaring difference. My globals are the same between versions, as are my
sources. I can surely provide copies of configs for review as well. I've
tried every option that I've seen, from the documentation and various
threads. It seems like this should be feasible, as with the previous
version, it just worked with no additional tweaking.

Any help is greatly appreciated!!

Jeremy Holt
GIS Consultant
Applied Data Consultants, Inc.
715-874-4397 ext. 243
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/mapproxy/attachments/20130711/d3674e8b/attachment.html>

More information about the MapProxy mailing list