[MapProxy] 404 error when attempting to seed from arcgis source

EVANS Wayne Wayne.EVANS at frequentis.com
Fri Feb 3 07:29:49 PST 2017

Hi Holger / Travis

Thanks for the prompt replies!

The xxx in the url was just an attempt to redact some of the info...

The 900913 projection is not my choice - this has been the projection used since the system was initially set up several years ago...

I don’t know if the ArcGIS server supports the "Export Map" Operation - I do not control that server but I will check with the owner.

I tried going down to the layer level on the ArcGIS server but I still get the same error.

I tried changing the source to the arcgisonline server (I don’t have ssl setup on my mapProxy so I had to use http instead of https):

	    type: arcgis
	      url: http://server.arcgisonline.com/arcgis/rest/services/ESRI_StreetMap_World_2D/MapServer/0

Now I get a different error. In the debugger console it says:

	[10:15:27.174] GET http://server.arcgisonline.com/arcgis/rest/services/ESRI_StreetMap_World_2D/MapServer/0/export?	f=image&format=png&imageSR=900913&bboxSR=900913&bbox=-9138963.97583,3570373.5912,-9127651.29565,3581686.27139&size=1184,1184 [HTTP/1.1 400 Bad 	Request 129ms]

In the mapproxy console it says:

	[2017-02-03 10:12:16,211] mapproxy.source.wms - WARNING - could not retrieve WMS map: HTTP Error "http://server.arcgison
	&bbox=-9138963.97583,3570373.5912,-9127651.29565,3581686.27139&size=1184,1184": 400

On the web page it says :

	Error: Output format not supported.
	Code: 400

Is this because png is not supported?

I tried changing the services section in my mapproxy.yaml file (from the default # image_formats: ['image/jpeg'],  ['image/png'])  to just:

	image_formats: ['image/jpeg']

But it still seems to ask for png in the GET URL....?

The suggestion to use the arcgis online is a good idea - if I can get that working then I can go back to the local ArcGIS server provider and try and get it working with them.


-----Original Message-----
From: MapProxy [mailto:mapproxy-bounces at lists.osgeo.org] On Behalf Of Holger Schiebold
Sent: Friday, February 03, 2017 8:07 AM
To: mapproxy at lists.osgeo.org
Subject: Re: [MapProxy] 404 error when attempting to seed from arcgis source

the "xxx" in the url is correct?

i would prefer 3857 instead of the unofficial 900913

does your arcGIS server supports the "Export Map" Operation?

you can compare your request with arcgisonline rest service for 
world_street_map for example - the request paramters generated from 
mapproxy delivers an image  at St.George

Am 02.02.2017 um 23:17 schrieb EVANS Wayne:
> Hi List,
> I am a MapProxy newbie - I have been working with a system that was set up by others to use WMS / tile sources. (I have previously successfully run seeds with WMS sources using locally stored raw data files.)
> I am now trying to add an ArcGIS source which is provided by the customers GIS department and will be updated automatically weekly so that we can pull updates via this system rather than having to copy raw data files over.
> The MapProxy is running on a Windows7 machine.
> I had to upgrade from 1.5 to 1.9.1 before the MapProxy demo would start with the ArcGIS source defined. Now when I try to run a seed I get 404 errors:
> An error occured. Retry in 256 seconds: SourceError('HTTP Error "http://hvg-app-d004.abc.dev/arcgis/rest/services
> /xxx/layer_Fill_trans/MapServer/export?f=image&format=png&imageSR=900913&bboxSR=900913&bbox=-9138963.97583,3570373.5912,-9
> 127651.29565,3581686.27139&size=1184,1184": 404',). Retries left: 93
> When I copy and paste this URL into a web browser (on the same MapProxy machine) I do not get a 404 - I get a webpage that appears to have a blank white page. This makes me suspect that maybe there is something blocking the traffic from the MapProxy application to the ArcGIS Server??
> I do not control either the MapProxy server (PC) or the ArcGIS server - I am the System Engineer in the middle trying to interface between a map update provider and a GeoServer / GeoWebCache based map function on a proprietary application that my company provides. (I am also not the one who architected this solution...)
> I also get errors when I click on the png or jpeg Demo link for the same layer on the MapProxy Demo webpage. (Is this pulled from the cache or does it come directly from the source?)
> Are the bounds, max image settings etc. configured on the arcgis server critical to getting this to work correctly?
> My relevant MapProxy configuration for the arcgis source is:
> services:
>    demo:
>    kml:
>    tms:
>      # needs no arguments
>    wmts:
>    wms:
>      # srs: ['EPSG:4326', 'EPSG:900913']
>      # image_formats: ['image/jpeg', 'image/png']
>      md:
>        # metadata used in capabilities documents
>        title: MapProxy WMS Proxy
>        abstract: This is the fantastic MapProxy.
>        online_resource: http://mapproxy.org/
>        contact:
>          person: Your Name Here
>          position: Technical Director
>          organization:
>          address: Fakestreet 123
>          city: Somewhere
>          postcode: 12345
>          country: Germany
>          phone: +49(0)000-000000-0
>          fax: +49(0)000-000000-0
>          email: info at omniscale.de
>        access_constraints:
>          This service is intended for private and evaluation use only.
>          The data is licensed as Creative Commons Attribution-Share Alike 2.0
>          (http://creativecommons.org/licenses/by-sa/2.0/)
>        fees: 'None'
> layers:
>    - name: frq_abc_florida_layer_fill_proxy
>      title: frq_abc_florida_layer_fill_proxy
>      sources: [frq_abc_florida_layer_fill_cache]
> caches:
>    frq_abc_florida_layer_fill_cache:
>      grids: [bing_grid]
>      sources: [frq_abc_layer_fill_arcgissource]
>      cache:
>        type: file
> sources:
>    frq_abc_layer_fill_arcgissource:
>      type: arcgis
>      req:
>        url: http://hvg-app-d004.abc.dev/arcgis/rest/services/xxx/layer_Fill_trans/MapServer
> globals:
>    # # coordinate transformation options
>    # srs:
>    #   # WMS 1.3.0 requires all coordiates in the correct axis order,
>    #   # i.e. lon/lat or lat/lon. Use the following settings to
>    #   # explicitly set a CRS to either North/East or East/North
>    #   # ordering.
>    #   axis_order_ne: ['EPSG:9999', 'EPSG:9998']
>    #   axis_order_en: ['EPSG:0000', 'EPSG:0001']
>    #   # you can set the proj4 data dir here, if you need custom
>    #   # epsg definitions. the path must contain a file named 'epsg'
>    #   # the format of the file is:
>    #   # <4326> +proj=longlat +ellps=WGS84 +datum=WGS84 +no_defs  <>
>    #   proj_data_dir: '/path to dir that contains epsg file'
>    # # cache options
>    cache:
>      # where to store the cached images
>      base_dir: './cache_data'
>      # where to store lockfiles
>      lock_dir: './cache_data/locks'
>    #   # request x*y tiles in one step
>    #   meta_size: [4, 4]
>    #   # add a buffer on all sides (in pixel) when requesting
>    #   # new images
>    #   meta_buffer: 80
>    # image/transformation options
>    image:
>          paletted: false
>          #One of nearest, bilinear or bicubic.
>          resampling_method: bicubic
> Any suggestions you have regarding what could be the cause of these errors would be appreciated!
> Thanks, Wayne
> _______________________________________________
> MapProxy mailing list
> MapProxy at lists.osgeo.org
> https://lists.osgeo.org/mailman/listinfo/mapproxy

mit freundlichen Grüßen

Holger Schiebold

codematix GmbH
Felsbachstrasse 5/7
D-07745 Jena
Tel. +49 (3641) 3038-34

MapProxy mailing list
MapProxy at lists.osgeo.org

More information about the MapProxy mailing list