[MapProxy] eventlet error

Märt Reose Mart.Reose at smit.ee
Wed Feb 8 14:10:14 PST 2017

Funny, I am having issues with demo site with gevent and without it. Using mapproxy 1.9.0 and gunicorn 19.6.0.

From browser:
GET http://mapservice.smit.dev/mapproxy/demo/static/site.css net::ERR_CONTENT_LENGTH_MISMATCH
(index):12 GET http://mapservice.smit.dev/mapproxy/demo/static/logo.png net::ERR_CONTENT_LENGTH_MISMATCH
favicon.ico:1 GET http://mapservice.smit.dev/favicon.ico 404 (Not Found)

From log:
[2017-02-08 23:48:26 +0000] [24056] [CRITICAL] WORKER TIMEOUT (pid:24062)
[2017-02-08 23:48:26 +0000] [24056] [CRITICAL] WORKER TIMEOUT (pid:24063)

Tried with keeping only wms and demo service. But same thing.
Installed mime types, still the same thing.

Strace is attached. (strace and the log are done at different times, the pids wont match, but contents are the same)

About systemd, gunicorn-s manual has an example using unix sockets: http://docs.gunicorn.org/en/stable/deploy.html

I am running basically what gunicorn has specified, but without unix socket and with the -b localhost:8080. Everything works perfectly, but not the demo site.


From: MapProxy [mailto:mapproxy-bounces at lists.osgeo.org] On Behalf Of Andrew Terry
Sent: Wednesday, February 08, 2017 8:48 PM
To: MapProxy at lists.osgeo.org
Subject: Re: [MapProxy] eventlet error

Thanks Travis, it’s very hard to know where you’re failing with that systemd until you’ve done it once. I almost had it sorted, just a permissions issue on the User/Group.

Much appreciated, might be a useful update to the documentation for others?


Subject: Re: [MapProxy] eventlet error

Pretty basic setup

cat /etc/systemd/system/mapproxy.service
Description=Gunicorn instance to serve MapProxy

ExecStart=/usr/bin/gunicorn -t 60 -k eventlet -w 5 -b localhost:8080 config:application


On 7 February 2017 at 17:13, Andrew Terry <andrew.terry at centremaps.co.uk<mailto:andrew.terry at centremaps.co.uk>> wrote:
Hi, thanks for the response. Yes, I’m using 1.9.

If I’m reading that example correctly, the issue there shows as a failing of an osm layer. This however is that the openlayers implementation isn’t getting called through. Runs ok with gevent or no -k entry for gunicorn.

Would greatly appreciate an example of a systemd service config if you have one you can share


Subject: Re: [MapProxy] eventlet error

Are you using mapproxy 1.9?  Could the issue be this - https://github.com/mapproxy/mapproxy/issues/239

BTW centos 7+ is the same requiring the use of systemd instead of upstart

On 7 February 2017 at 07:44, Andrew Terry <andrew.terry at centremaps.co.uk<mailto:andrew.terry at centremaps.co.uk>> wrote:

Just setting up on Ubuntu xenial and generally everything working fine. Oddly though, with gunicorn (18.0) and eventlet I get an error loading the openlayers in the browser demo. Shows “ReferenceError: OpenLayers is not defined”.

However, using gevent instead of eventlet or not specifying anything does work. I plan to continue with gevent in place but happy to hear if anyone knows the issue.

Also now creating a systemd startup as it seems the old init is discontinued in xenial (without installing upstart).


MapProxy mailing list
MapProxy at lists.osgeo.org<mailto:MapProxy at lists.osgeo.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/mapproxy/attachments/20170208/004f552f/attachment-0001.html>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: mapproxy-demo-strace.txt
URL: <http://lists.osgeo.org/pipermail/mapproxy/attachments/20170208/004f552f/attachment-0001.txt>

More information about the MapProxy mailing list