[MapProxy] eventlet error

Andrew Terry andrew.terry at centremaps.co.uk
Thu Feb 9 01:17:17 PST 2017

Hi Travis, agreed! I’ve been looking to see whether the various forums discussing static files with nginx/gunicorn/Django provide a clue. Seems from those that static files should be put in a specific directory and called directly via nginx? I presume that this was something different for gunicorn 19.X than 18.X?

If so, I’m planning to have a go at getting 19 to work with the static file settings in nginx. If this is a more fundamental issue, it would be great to know as that’ll be beyond my capabilities I suspect!


From: Travis Kirstine [via OSGeo.org] [mailto:ml-node+s1560n5307080h94 at n6.nabble.com]
Sent: 09 February 2017 00:44
Subject: Re: [MapProxy] eventlet error

This is another bug - http://osgeo-org.1560.x6.nabble.com/MapProxy-tms-request-via-gunicorn-td5284583.html
you have to revert to gunicorn 1.8.X

Glad to see we all are running into the same issues :)

On 8 February 2017 at 17:10, Märt Reose <[hidden email]</user/SendEmail.jtp?type=node&node=5307080&i=0>> wrote:
Funny, I am having issues with demo site with gevent and without it. Using mapproxy 1.9.0 and gunicorn 19.6.0.

From browser:
GET http://mapservice.smit.dev/mapproxy/demo/static/site.css net::ERR_CONTENT_LENGTH_MISMATCH
(index):12 GET http://mapservice.smit.dev/mapproxy/demo/static/logo.png net::ERR_CONTENT_LENGTH_MISMATCH
favicon.ico:1 GET http://mapservice.smit.dev/favicon.ico 404 (Not Found)

From log:
[2017-02-08 23:48:26 +0000] [24056] [CRITICAL] WORKER TIMEOUT (pid:24062)
[2017-02-08 23:48:26 +0000] [24056] [CRITICAL] WORKER TIMEOUT (pid:24063)

Tried with keeping only wms and demo service. But same thing.
Installed mime types, still the same thing.

Strace is attached. (strace and the log are done at different times, the pids wont match, but contents are the same)

About systemd, gunicorn-s manual has an example using unix sockets: http://docs.gunicorn.org/en/stable/deploy.html

I am running basically what gunicorn has specified, but without unix socket and with the -b localhost:8080. Everything works perfectly, but not the demo site.


From: MapProxy [mailto:[hidden email]</user/SendEmail.jtp?type=node&node=5307080&i=1>] On Behalf Of Andrew Terry
Sent: Wednesday, February 08, 2017 8:48 PM
To: [hidden email]</user/SendEmail.jtp?type=node&node=5307080&i=2>

Subject: Re: [MapProxy] eventlet error

Thanks Travis, it’s very hard to know where you’re failing with that systemd until you’ve done it once. I almost had it sorted, just a permissions issue on the User/Group.

Much appreciated, might be a useful update to the documentation for others?


Subject: Re: [MapProxy] eventlet error

Pretty basic setup

cat /etc/systemd/system/mapproxy.service
Description=Gunicorn instance to serve MapProxy

ExecStart=/usr/bin/gunicorn -t 60 -k eventlet -w 5 -b localhost:8080 config:application


On 7 February 2017 at 17:13, Andrew Terry <[hidden email]</user/SendEmail.jtp?type=node&node=5307080&i=3>> wrote:
Hi, thanks for the response. Yes, I’m using 1.9.

If I’m reading that example correctly, the issue there shows as a failing of an osm layer. This however is that the openlayers implementation isn’t getting called through. Runs ok with gevent or no -k entry for gunicorn.

Would greatly appreciate an example of a systemd service config if you have one you can share


Subject: Re: [MapProxy] eventlet error

Are you using mapproxy 1.9?  Could the issue be this - https://github.com/mapproxy/mapproxy/issues/239

BTW centos 7+ is the same requiring the use of systemd instead of upstart

On 7 February 2017 at 07:44, Andrew Terry <[hidden email]</user/SendEmail.jtp?type=node&node=5307080&i=4>> wrote:

Just setting up on Ubuntu xenial and generally everything working fine. Oddly though, with gunicorn (18.0) and eventlet I get an error loading the openlayers in the browser demo. Shows “ReferenceError: OpenLayers is not defined”.

However, using gevent instead of eventlet or not specifying anything does work. I plan to continue with gevent in place but happy to hear if anyone knows the issue.

Also now creating a systemd startup as it seems the old init is discontinued in xenial (without installing upstart).


MapProxy mailing list
[hidden email]</user/SendEmail.jtp?type=node&node=5307080&i=5>

MapProxy mailing list
[hidden email]</user/SendEmail.jtp?type=node&node=5307080&i=6>

MapProxy mailing list
[hidden email]</user/SendEmail.jtp?type=node&node=5307080&i=7>
If you reply to this email, your message will be added to the discussion below:
To unsubscribe from MapProxy, click here<http://osgeo-org.1560.x6.nabble.com/template/NamlServlet.jtp?macro=unsubscribe_by_code&node=4332432&code=YW5keUBjZW50cmVtYXBzLmNvLnVrfDQzMzI0MzJ8LTE3NDM2MTI2>.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/mapproxy/attachments/20170209/0fe3db5c/attachment-0001.html>

More information about the MapProxy mailing list