[MapProxy] WMTS srs not supported

Andrew Terry andrew.terry at centremaps.co.uk
Wed Mar 8 05:21:21 PST 2017

Hi Oliver,

I was hoping I had made a silly mistake but believe I have set one up:


    srs: 'EPSG:29902'
    bbox: [145000, 310000, 370000, 470000]
    # res: [1250,625,312.5]
    # res: [2500,1250,625,315,160,80,40,20,10,5,2.5,1,0.5,0.25,0.125,0.06,0.03]
    max_res: 0.03
    min_res: 1250
    res_factor: sqrt2
    origin: 'nw'

I've tried a couple of grid types as you can see from the commented out ones - I also tried specifying the bbox srs as well just incase.

One thing I did notice which may not simply be my error is that when I added the proj data file option to one multimapp yaml it broke the others I had set up. I presume that, should I actually need an unsupported proj, I should put it in all yamls?

Also, is there any efficiency improvement to using an epsg and only having the projections listed that I intend to support?



-----Original Message-----
From: Oliver Tonnhofer [mailto:olt at omniscale.de] 
Sent: 08 March 2017 11:28
To: Andrew Terry <andrew.terry at centremaps.co.uk>
Cc: MapProxy at lists.osgeo.org
Subject: Re: [MapProxy] WMTS srs not supported

The warning means that srs is not a valid option for WMTS services.
You need to create another tile grid in EPSG:29902 if you want to support multiple projections in WMTS.


Oliver Tonnhofer  | Omniscale GmbH & Co KG  | https://omniscale.com
OpenStreetMap WMS and tile services         | https://maps.omniscale.com

> On 07.03.2017, at 13:27, Andrew Terry <andrew.terry at centremaps.co.uk> wrote:
> Hi,
> I’ve been working with GB EPSG:27700 fine but have just begun on some Northern Ireland (EPSG:29902) data.
> I can’t seem to get a cache or WMTS set up for this EPSG. Running serve-develop I see an issue with “unknown ‘srs’ in services.wmts”
> WMS does work – although there is no cache
> I have also tried creating and epsg file and I still get the warning although oddly I get the info about the proj data being loaded after the warning about the unknown ‘srs’ in services.wmts
> [2017-03-07 12:07:47,537] mapproxy.config - INFO - reading: /etc/opt/mapproxy/mapproxy.yaml
> [2017-03-07 12:07:47,553] mapproxy.config - WARNING - unknown 'srs' in services.wmts
> [2017-03-07 12:07:47,556] mapproxy.system - INFO - loading proj data from /etc/opt/mapproxy/mp_projs/
> Am I overlooking anything obvious?
> Also, when I created the epsg file I only added:
> <29902> +proj=tmerc +lat_0=53.5 +lon_0=-8 +k=1.000035 +x_0=200000 +y_0=250000 +a=6377340.189 +b=6356034.447938534 +units=m +no_defs <>
> Is there a file I can copy the rest of the default mapproxy supported projections from?
> Thanks in advance
> Andy
> _______________________________________________
> MapProxy mailing list
> MapProxy at lists.osgeo.org
> https://lists.osgeo.org/mailman/listinfo/mapproxy

More information about the MapProxy mailing list