[mapserver-dev] Mapserver from commandline hanging

Lime, Steve D (DNR) Steve.Lime at state.mn.us
Wed Feb 17 14:13:41 EST 2010

Multiple libpq's on the system?

-----Original Message-----
From: mapserver-dev-bounces at lists.osgeo.org [mailto:mapserver-dev-bounces at lists.osgeo.org] On Behalf Of strk
Sent: Wednesday, February 17, 2010 11:26 AM
To: mapserver-dev at lists.osgeo.org
Subject: [mapserver-dev] Mapserver from commandline hanging

I'm trying to run 'mapserv' from commandline to test
some parameters more quickly, but surprisingly it hangs
deep in libpq for unknown reasons.

The *same* executable, with the *same* mapfile runs fine
if invoked by apache (CGI).

GDB reports the hanging being deep in libpq:

  [Wed Feb 17 18:21:35 2010].616193 msWMSLoadGetMapParams(): enabling non-square pixels.
  [Wed Feb 17 18:21:35 2010].617987 msDrawMap(): kicking into non-square pixel preserving mode.
  Program received signal SIGINT, Interrupt.
  0xffffe430 in __kernel_vsyscall ()
  (gdb) bt
  #0  0xffffe430 in __kernel_vsyscall ()
  #1  0xb70c366b in poll () from /lib/libc.so.6
  #2  0xb73e87f5 in pqSocketCheck () from /usr/lib/libpq.so.5
  #3  0xb73e88ea in pqWaitTimed () from /usr/lib/libpq.so.5
  #4  0xb73e3a96 in connectDBComplete () from /usr/lib/libpq.so.5
  #5  0xb73e46a5 in PQconnectdb () from /usr/lib/libpq.so.5
  #6  0x081341ea in msPostGISLayerOpen ()
  - Wed Feb 17 18:23:48 CET 2010 -

Attempts to connect (using the data in the CONNECTION string) from the
same shell I run 'mapserv' succeed with no problems.

I tried with mapserver-5.4.2 and mapserver-trunk-9796 with same results.

Any idea ?


  ()   Free GIS & Flash consultant/developer
  /\   http://foo.keybit.net/~strk/services.html
mapserver-dev mailing list
mapserver-dev at lists.osgeo.org

More information about the mapserver-dev mailing list