[mapserver-dev] PHP 5.2.0

Alan Boudreault aboudreault at mapgears.com
Thu Jul 22 15:18:34 EDT 2010

Hi Bart,

IIRC, yes there was reasons why I bumped the required version to 5.2. Since 
the php mapscript has been refactored, a few things need a recent zend engine. 
At that time, I checked Debian Etch (which is old..) and noticed php 5.2.x was 
available in that distribution. So I thought it was a reasonable decision.

I am mostly sure that php 5.2.x has been built for RHEL 5 and is supported by 
the users community. Hovewer, I understand your point and agree that a few 
people might be reluctant to that change. 


On July 19, 2010 07:37:18 am Bart van den Eijnden (OSGIS) wrote:
> Hi list,
> trunk has a PHP 5.2.0 dependency since r9937 [1].
> What change required this? Does this mean PHP 5.1.6 won't work or it isn't
> supported?
> We are currently running Red Hat Enterprise 5 which comes with PHP 5.1.6
> so it's kind of a problem :-)
> [1] http://trac.osgeo.org/mapserver/changeset/9937
> Best regards,
> Bart

Alan Boudreault

More information about the mapserver-dev mailing list