[mapserver-dev] python mapscript compile causes error

Guillaume Sueur no-reply at neogeo-online.net
Wed Feb 29 03:29:49 EST 2012

Le 28/02/12 21:52, Umberto Nicoletti a écrit :
> This ticket should have information and a patch to help you fix your issue:
> http://trac.osgeo.org/mapserver/ticket/3940

Exact. Same workaround as the one I've found in mapscript.py

> Which python version are you using, btw?


I did test the pymodule.i patch and it worked well for me. It's worth 
than having to patch mapscript.py everytime you make a new build of it. 
I hope to see it committed soon ;-)

Thanks for your help, the bug title wasn't clearly related to the 


> On Tue, Feb 28, 2012 at 5:32 PM, Guillaume Sueur
> <no-reply at neogeo-online.net <mailto:no-reply at neogeo-online.net>> wrote:
>     Hi list,
>     I did my own compile of mapscript after some modifications in
>     mapogcsld.c file, and if the things went well, I ran into two
>     similar errors provided by mapscript.py but not directly connected
>     to the modifications I've made.
>     On lines 823 and 1371, instead of having __init__(self, *args) like
>     in mapscript genuine version, there was respectively :
>     def __init__(self, layer = None):
>     and
>     def __init__(self, map = None):
>     which caused following lines using args to raise an exception.
>     I don't understand why it occured (maybe swig configuration or
>     whatever) and would appreciate any clue about this.
>     Best regards
>     Guillaume
>     _________________________________________________
>     mapserver-dev mailing list
>     mapserver-dev at lists.osgeo.org <mailto:mapserver-dev at lists.osgeo.org>
>     http://lists.osgeo.org/__mailman/listinfo/mapserver-dev
>     <http://lists.osgeo.org/mailman/listinfo/mapserver-dev>

More information about the mapserver-dev mailing list