[mapserver-dev] error in php_mapscript_util.c

Ivo Karabojkov karabojkov at kit-bg.com
Sun Jul 1 12:24:11 PDT 2012

Following your advice I downloaded git-master from 
I used ZIP and extracted it to my server. The file I downloaded is:
(I think this contains exact code version)

This is the first time for me to compile manually without using FreeBSD
PORTS collection. I am doing my best to follow instructions on 
So, I have trouble on the very first step: ./configure
The message is:

configure: error: png.h header not found. install png development package,
or reconfigure with --with-png=/path/to/png/prefix

I tried to point both location of png.h:
(both are identical).
No matter what I pointed to configure (the path to png.h ot png.h itself) I
had the same message over and over again:
configure: error: png.h header not found in /usr/local/include. install png
development package, or reconfigure with --with-png=/path/to/png/prefix

I have png-1.5.11 installed from ports. I tried to remove and reinstall with
same result.
In the meantime official port of mapserver to FreeBSD (v. 6.0.1 with broken
PHP MapScript at least for PHP 5.4) was marked as broken:
- Mark BROKEN: does not link
  /usr/local/lib/libgdal.so: undefined reference to `pthread_create'
  gmake: *** [shp2img] Error 1

Do you think I have problem with my OS support, package versions or
something else?
Thanks again!

Jeff McKenna wrote
> Actually I fixed this about a month ago, you will have to use MapServer
> git-master to get it for now though, as it will be in the upcoming 6.2
> release.  If you want to test the changes please do so and provide
> feedback at https://github.com/mapserver/mapserver/issues/4309
> Thank you.
> -jeff
> -- 
> Jeff McKenna
> MapServer Consulting and Training Services
> http://www.gatewaygeomatics.com/
> _______________________________________________
> mapserver-dev mailing list
> mapserver-dev at .osgeo
> http://lists.osgeo.org/mailman/listinfo/mapserver-dev

View this message in context: http://osgeo-org.1560.n6.nabble.com/error-in-php-mapscript-util-c-tp4654681p4985180.html
Sent from the Mapserver - Dev mailing list archive at Nabble.com.

More information about the mapserver-dev mailing list