[mapserver-dev] UVRaster RLatLon GRIB2 data not working properly on Mapserver

Jeff McKenna jmckenna at gatewaygeomatics.com
Fri Jan 21 12:14:27 PST 2022

Hi Felix,

Thanks for including all of the files.

I ran this locally, with MS4W 5.0 beta2 (MapServer 8.0-dev, GDAL 3.4.0, 
PROJ 8.2.0) using the map2img commandline utility (or "shp2img" for 
earlier MapServer versions) and received what looks like a valid map 
image each time:

- map image: https://pasteboard.co/2mTyHAzprtQk.png

- command:

   map2img -m uvraster.map -e -154 26 -42 70 -l "HRDPS.CONTINENTAL_UU" 
-o ttt.png -map_debug 3

- command's debug output: https://pastebin.com/qPsHr4wJ

My output appears valid, I think.  I wonder if you are having a PROJ 
issue (try upgrading to MapServer-main and PROJ 8, and re-test)

Hope this somewhat helps,

Have a nice weekend, and hello from the east coast.


Jeff McKenna
GatewayGeo: Developers of MS4W, MapServer Consulting and Training
co-founder of FOSS4G

On 2022-01-21 3:08 p.m., Laframboise,Felix (ECCC) wrote:
> Hi,
> I am currently using GDAL 3.1.3 and Mapserver 7.6.2 on a Ubuntu machine. 
> I created a UVRaster layer with a style using arrow symbols. The source 
> data is GRIB2 files using a Rotated Latitude-Longitude grid data (RLatLon).
> When I tested the layer, I noticed that it does not output correctly. 
> Sometimes, no image outputs, and sometimes all the arrows/data seem to 
> be clustered somewhere on the extent. The expected extent should be the 
> one of North America (approximatively [-154, 26, -42, 70] in the 
> /[min_x, min_y, max_x, max_y]/ format), where all the arrows are spread 
> out on this extent.
> Following this output, I did investigate the issue, and the mapfile is 
> working fine as I tested it with other data that is not using a RLatLon 
> grid.
> I created a test case to show you the issue here:
> ·Sample mapfile: https://pastebin.com/h06AsJzz 
> <https://pastebin.com/h06AsJzz>
> ·Sample VRT: https://pastebin.com/ERViMRpR
> ·2 UV GRIB2 files (available here: 
> https://dd.weather.gc.ca/model_hrdps/continental/2.5km/grib2/00/000/ 
> <https://dd.weather.gc.ca/model_hrdps/continental/2.5km/grib2/00/000/> ) 
> for the source data (using following patterns) :
> o/*_MSC_HRDPS_UGRD_AGL-40m_RLatLon0.0225_*.grib2/
> o/*_MSC_HRDPS_VGRD_AGL-40m_RLatLon0.0225_*.grib2/
> ·Output image when arrows are clustered: 
> https://pasteboard.co/WMoun7bhLZSl.png 
> <https://pasteboard.co/WMoun7bhLZSl.png>
> We serve the mapfiles using Python mapscript but I tested the mapfiles 
> with a mapserv command and got the same result.
> Do you have an idea what could be the issue and how to solve it? RLatLon 
> data is working fine with Mapserver, but it seems to only affect 
> UVraster layers.
> Thanks a lot in advance for your answer(s)!
> Félix Laframboise
> _______________________________________________
> MapServer-dev mailing list
> MapServer-dev at lists.osgeo.org
> https://lists.osgeo.org/mailman/listinfo/mapserver-dev

More information about the MapServer-dev mailing list