RIF: [Mapserver-users] Problems with ECW images, update

Rutigliano Saverio Rutigliano.Saverio at minambiente.it
Sat May 29 19:52:23 EDT 2004

It seems to be ok... but not completely.

1.	1. The gdal12.dll version from "openEV" depends on many other dlls apparently not necessary for mapserver usage.
	I could easily recompile the dll using last gdal cvs version and it works fine. (tell me if you want me to send you the file)
2.	There are still cases where it seems ECW support have problems: I can't be able to zoom in if metre/pixel ratio is less than 4. It happens only with a particular ECW file (about 6 Giga, but not the larger I've!). I tested this file with ermapper products (ER Viewer) and It seems to be OK... so what?.
	This is the error I get using shp2img.exe:
	D:\OpenEV_FW\bin>shp2img -m test.map -o test-campania.png
	msDrawMap(): Image handling error. Failed to draw layer named 'Ortofoto-colori'.
	NCScbmReadViewLineBIL failed.: Unable to access file. GDALRasterIO() failed: dra
	wGDAL() <br>
3.	It seems that at this moment support for HFA format (Erdas Imagine Images (.img)) is broken at 1.2.0. It worked VERY WELL at 1.1.9. With this last release simply nothing happens when using a .img raster file!

Saverio Rutigliano
saveriorutigliano at libero.it <mailto:saveriorutigliano at libero.it> 

	-----Messaggio originale----- 
	Da: mapserver-users-admin at lists.gis.umn.edu per conto di Armin Burger 
	Inviato: mer 26/05/2004 13.59 
	A: mapserver-users at lists.gis.umn.edu 
	Oggetto: Re: [Mapserver-users] Problems with ECW images, update

	I tried now a new version of the 'gdal12.dll' that was delivered with the
	latest OpenEV software package (version 1.7.4) from Frank Warmerdam and that
	seemed to solve the problem. So both test ECW images don't cause any more
	> Hi
	> I experienced sometimes problems with ECW images. It worked fine for a
	> Landsat image (25 m resolution) and scales smaller than e.g. 1:100000.
	> zoominng in the ECW layer seems to cause errors. I checked with shp2img
	> setting an extent similar to the higher scale that caused problems. Then
	> sh2img.exe crashed and I got the error
	> ERROR 7: Assertion `iDstLine == 0' failed
	> in file `ecwdataset.cpp', line 346
	> The same happened with a high resolution image (0.8 m pixel) and scale
	> above 1:5000.
	> I tried with the shp2img.exe from the DM Solution
	> 'mapserver-4.0.2-win32-php4.3.4.zip'  that uses the 'gdal12.dll'
	> Any ideas what could be the problem?
	> Armin
	> _______________________________________________
	> Mapserver-users mailing list
	> Mapserver-users at lists.gis.umn.edu
	> http://lists.gis.umn.edu/mailman/listinfo/mapserver-users
	NEU : GMX Internet.FreeDSL
	Ab sofort DSL-Tarif ohne Grundgebühr: http://www.gmx.net/dsl
	Mapserver-users mailing list
	Mapserver-users at lists.gis.umn.edu

More information about the mapserver-users mailing list