[osgeo4w-dev] Problems

Frank Warmerdam warmerdam at pobox.com
Tue Sep 2 10:02:42 EDT 2008

Derek Bain wrote:
> Hi
> I am having the following problems with OSGeo4W,
> 1.I can get ENC's to work with MapServer v5.0.2 and v5.2.0, however with
> OSGeo4W ENC's cause an exception within MapServer. I have tried to debug
> this but get lots of windows appearing. However, I managed to get something
> which I have attached. My map file works okay with shp2img. Does anyone know
> what the cause of this problem may be?


Hmm, this is somewhat odd.  Can you reproduce the problem with mapserv.exe
at the shell commandline or is it only when used under Apache?  I am wondering
if the Apache environment does not have the proper settings to find the
S-57 support files, though I would not expect that to result in a crash.

When you say things work with MapServer 5.0.2 but not 5.2.0, do you mean
within the OSGeo4W environment?  That is, does dropping back to the 5.0.2
version in OSGeo4W fix the problem again?

> 2. For ECW's and JPEG2000, I get the following error "EPPL7 support is not
> available on this build". This worked with MapServer 5.0.2 & v5.2.0 but not
> the OSGeo4W version. I assume the OSGeo4W build of MapServer does not
> support ECW and JPEG2000.

To enable the ECW and JP2ECW drivers you will need to install the gdal-ecw
plugin package:


> 3 When viewing GeoTiffs and shapefiles I get a large area around my image
> covered in pink (transparency color) This did not happen in v5.0.2. I have
> attached a file showing the output.

Something when wrong when I tried to download the attachments so I haven't
seen them.   Once again, is this something that broke in moving from 5.0.2
within OSGeo4W to 5.2.0?

Best regards,
I set the clouds in motion - turn up   | Frank Warmerdam, warmerdam at pobox.com
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush    | Geospatial Programmer for Rent

More information about the osgeo4w-dev mailing list