[osgeo4w-dev] EPPL7 problem still exists

Yewondwossen Assefa yassefa at dmsolutions.ca
Tue Sep 16 11:27:35 EDT 2008

Couple of thinks to check:

   doing a  gdalinfo --formats , you should be able to see in that list:

   ECW (rw): ERMapper Compressed Wavelets
   JP2ECW (rw+): ERMapper JPEG2000

  That would tell you that the gdal plugin for ecw ( 
gdal_ECW_JP2ECW.dll) is properly installed, and also that the the ECW 
related dlls are installed properly (from the ERMapper SDK).

  If that is the case, I am assuming that there is something wrong with 
your ecw file.

  If you don't the ECW support in the list of formats, that would 
suggest that there is something not installed properly (some tips: make 
sure that you have  osgeo4w/bin/gdalplugins/gdal_ECW_JP2ECW.dll, make 
sure that the folder (contaning NSCEcw.dll ...) of the SDK you installed 
are in your path, according to 
http://trac.osgeo.org/osgeo4w/wiki/pkg-gdal-ecw ).

Best Regards,

Derek Bain wrote:
> Hi Assefa
> Thanks for the reply. Tried gdalinfo and that failed. Tried on jpeg2000 
> file and that failed as well. Tried on GeoTiff and that worked ok.
> See below for output
> C:\OSGeo4W\bin>gdalinfo d:\test_maps\data\Mosaic_0.ecw
> ERROR 4: `d:\test_maps\data\Mosaic_0.ecw' not recognised as a supported 
> file format.
> gdalinfo failed - unable to open 'd:\test_maps\data\Mosaic_0.ecw'.
> Thanks
> Derek
> ------------------------------------------------------------------------
> _______________________________________________
> osgeo4w-dev mailing list
> osgeo4w-dev at lists.osgeo.org
> http://lists.osgeo.org/mailman/listinfo/osgeo4w-dev

Assefa Yewondwossen
Software Analyst

Email: assefa at dmsolutions.ca

Phone: (613) 565-5056 (ext 14)
Fax:   (613) 565-0925

More information about the osgeo4w-dev mailing list