[osgeo4w-dev] Re: [Qgis-developer] cannot build qgis with python inside osgeo4w: python isn't detected

G. Allegri giohappy at gmail.com
Mon Mar 30 12:19:06 EDT 2009

Solved this too :) it was looking into my system env var, not in the
osgeo4w one...
Everything is there, except grass! The grassplugin.dll is in the
plugins folder, but it doesn't appear in qgis!!!!!

2009/3/30 G. Allegri <giohappy at gmail.com>:
> Ok, solved with your script. I had to fix something for my machine,
> but the only difference seems to be the egre part...
> Anyway the grassplugin gets compiled.
> Now, the installed qgis.exe raises another error. Cannot find an entry
> procedure in QtCore4.dll:
> http://yfrog.com/0rqgisstartdp
> 2009/3/30 G. Allegri <giohappy at gmail.com>:
>> Now I receive a linking error, that says the grass_vect.lib is broken
>> as FATA ERROR 1127... What could cause this?
>> 2009/3/30 G. Allegri <giohappy at gmail.com>:
>>>> Please don't.  CMake follows convensions.  It knows that libraries are
>>>> called name.lib for MSVC and libname.a for Unix (and MinGW).   If you
>>>> change FindGRASS you break it for other platforms.
>>> Ok, I will.
>>>> My incarnation of that script is on http://buten.norbit.de/~jef/mklibs.
>>>> That also takes care of the lib renaming and removes the version tag
>>>> from the libraries.
>>> It seems to do the same as mine.
>>> I've made it work... it was an error of extra characters inserted by
>>> notepad. I had to remove them with an hex editor!

More information about the osgeo4w-dev mailing list