[osgeo4w-dev] [osgeo4w] #199: multiple GDAL versions used

OSGeo4W trac_osgeo4w at osgeo.org
Sun Nov 21 07:50:51 EST 2010

#199: multiple GDAL versions used
Reporter:  msieczka  |       Owner:  osgeo4w-dev@…              
    Type:  defect    |      Status:  new                        
Priority:  major     |   Component:  Package                    
 Version:            |    Keywords:                             
 I have just installed QGIS 1.6.0 via Express Install and in QGIS's Help >
 About I found out that it was built against GDAL 1.5.4 (released nearly 2
 years ago).

 Would there be any problem to build QGIS against recently released GDAL

 According to "%OSGEO4W_ROOT%"\bin\qgis.bat and Dependency Walker, it is
 run against 1.7.3 anyway. Also GdalTools QGIS plugin, enabled by default,
 depends on 1.7.3.

 BTW: could such mismatches between runtime and buildtime GDAL versions
 pose issues?

 GDAL 1.5.4 is still installed only as gpsbabel and OpenEV dependency
 AFAICT, and GDAL 1.6.3 as GRASS 6.4.0 dependency. Why isn't GDAL 1.7.3
 used everywhere instead?

 Current situation is puzzling and makes it harder to debug issues related
 to GDAL.

Ticket URL: <http://trac.osgeo.org/osgeo4w/ticket/199>
OSGeo4W <http://trac.osgeo.org/osgeo4w>
OSGeo4W is the Windows installer for the OSGeo stack.

More information about the osgeo4w-dev mailing list