[osgeo4w-dev] ANN: Python 2.7.4

Mikhail Titov mlt at gmx.us
Tue Apr 23 12:22:24 PDT 2013

On Sat, Apr 20, 2013 at  1:23 AM, Matt Wilkie <maphew-Re5JQEeQqe8AvxtiuMwx3w at public.gmane.org> wrote:
> Python 2.7.4 has been uploaded to the Osgeo4W download mirror and
> passes install tests on my machine. Please test on yours.

I suspect that this upgrade somehow breaks my QGIS installation. I tried
several times that downgrading python-core from 2.7.4-2 to 2.7.2-4 makes
it possible to at least start QGIS while subsequent upgrade makes QGIS
fail to start. It simply disappears after a splash screen saying
something like "Starting Python...".

I tried to isolate an issue as I have way too many python
installations. Here is how I tried to start QGIS (other than in a usual

,----[ qgis.bat ]
| @echo off
| SET PATH=%OSGEO4W_ROOT%\apps\Python27\Scripts;%OSGEO4W_ROOT%\bin
| rem ;%PATH%
| echo %PATH%
| "%OSGEO4W_ROOT%"\apps\qgis\bin\qgis.exe %*

So it says only "C:\OSGeo4W\apps\Python27\Scripts;C:\OSGeo4W\bin" in

Note that QGIS starts (with a reasonable amount of complaints) with
python-core 2.7.4-2 if I comment out everywhere PYTHONHOME so it is nil.

P.S. I'm running Windows XP 32 bit with SP3

More information about the osgeo4w-dev mailing list