[osgeo4w-dev] [osgeo4w] #683: Installer Support HTTPS

OSGeo4W trac_osgeo4w at osgeo.org
Tue Jul 13 08:50:00 PDT 2021

#683: Installer Support HTTPS
Reporter:  trockefeller  |      Owner:  osgeo4w-dev@…
    Type:  enhancement   |     Status:  new
Priority:  major         |  Component:  Installer
 Version:                |   Keywords:  https
 If I go to https://download.osgeo.org/osgeo4w/ inside of chrome, it looks
 like the download mirror does support https with a certificate from Let's
 Encyrpt, and as far as I can tell, I can download any file that I need to
 using HTTPS in my browser.

 If I don't explicitly go to the https site, it defaults to http instead of
 https, and there are certain files that I can't download from the http
 site like

 It appears to be getting blocked by our business's firewall, and is
 somehow related to maybe file type and or size of the file because I can
 download most files using http, but the larger files are blocked

 I see this when using the OSGeo4W installer as well, because the install
 will just halt at the download phase of these files that I can't download
 over http.

 My workaround has been to download the files that fail over http over
 https in my browser, and then I copy that file into the temp directory
 where the downloads are cached for the OSGeo4W installer and then restart
 the installer.

 I tried adding a "User URL" when choosing a download site, and tried
 putting in https://download.osgeo.org, but if I do that, it immediately
 fails saying "Can't open /x86_64/setup.ini.bz2" even though I can find and
 download that exact file at https://download.osgeo.org/osgeo4w/v2/x86_64/
 inside of my browser.

 I feel like HTTPS should be supported by the installer, and should really
 be the default for security reasons

Ticket URL: <https://trac.osgeo.org/osgeo4w/ticket/683>
OSGeo4W <http://trac.osgeo.org/osgeo4w>
OSGeo4W is the Windows installer and package environment for the OSGeo stack.

More information about the osgeo4w-dev mailing list