[OSGeoLive] OSGeo-live flash drive not detected on various platforms

Brian M Hamlin maplabs at light42.com
Wed Feb 16 15:07:23 PST 2022

Hi Jochen -

   thank you for this thorough documented test case. I also experienced 
in the USA, several models of modern laptop that prevent booting from 
USB in non-obvious ways. Sometimes this is documented; it was always the 
low cost models in my tests.

   regarding Macs and NTFS, Apple has stubbornly and for their own 
interest, declined to support basic data exchange with standard Linux 
format volumes, and mostly also Windows-style volumes.  Your workaround 
is not one I tried, but, I gave up this effort myself long ago. Apple is 
obstructing this basic functionality and they know it well.  Others on 
this list are talking about M1 processor Macs, and how to approach 
those. I wish it all well.

   thank you and best from Berkeley, Calif   --Brian M Hamlin /  

On 2/16/22 2:30 PM, Jochen Albrecht wrote:
> Let me start with the positive news: I distributed a 32 GB flash drive 
> to my 20 students and a good number of them could happily boot from 
> the NTFS-formatted flash drive and proceed. It all works well on the 
> eight-years old Dell computers in our labs.
> But I have not succeeded to help any of my Macintosh students and ran 
> into significant troubles with Lenovo and HP laptops.
> On the Mac side, I concluded that I needed to format the OSGeo-live 
> partition to HFS+. I then proceeded to use the Linux 'dd' command to 
> copy the iso file to the first partition, which resulted in the 
> partition format to switch to "ISO9660". The resulting flash drive is 
> still not detected on a variety of Macs
>   * Macbook Air (retina 13” 2019) , Intel(R) Core(TM) i5-8210Y CPU @
>     1.60GHz, Mac OS Big Sur version 11.6.
>   * MacBook Pro, 13-inch, 2020, four thunderbolt 3 ports; CPU: 2 GHz
>     Quad-Core Intel Core i5
> Lenovo ThinkPads and IdeaPads apparently cannot read boot drives that 
> are NTFS formatted but once I go back to FAT32, they boot properly. 
> Having said that, the Lubuntu system does not recognize the built-in 
> network cards and hence fails to connect both via ethernet cable or 
> wireless.
> HP laptops work only if "secure boot" is disabled in the BIOS and 
> "legacy support" enabled. Unfortunately, newer HP laptops don't seem 
> to have the legacy boot option anymore and so we are here stuck again 
> with the flash drive being invisible to my students.
> The last time I taught my Advanced GIS course with OSGeo-live flash 
> drives was in 2019 and back then I did not encounter any of the above 
> problems.
> So, after all this preambulation, here are my questions:
>  1. What do I need to do the get my Mac students set up (I do not have
>     a Mac and therefore need more hand holding here)
>  2. Is there a website (I searched the listserv archives to no avail)
>     that collects FAQs about installation problems?
>  3. Assuming that there is not, are there readers of this message who
>     have successfully circumvented the problems described with newer
>     laptops?
> I could be wrong but I believe that a bit of this is due to the 
> distribution being Lubuntu based, which has a much small community 
> that may not be as up-to-date with modern BIOS as other, larger Linux 
> distributions. Given that we are beyond the days of DVDs, might we 
> perhaps return to one of the heavyweights (Ubuntu, Fedora, Debian)?
> And a second suggestion: could the organizers of this listserv create 
> a FAQ related to installation issues? The support in that respect is 
> small and outdated. I would be happy to populate it with what I have 
> learned so far.
> Cheers,
>       Jochen
> _______________________________________________
> osgeolive mailing list
> osgeolive at lists.osgeo.org
> https://lists.osgeo.org/mailman/listinfo/osgeolive
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/osgeolive/attachments/20220216/3f36fba2/attachment-0001.html>

More information about the osgeolive mailing list