[pgrouting-users] pgrouting and openlayers php error

Muhammad Iqnaul Haq iqnaulhaq at gmail.com
Wed Feb 12 04:23:01 PST 2014

Hi all

I'm working to make a routing web-app using pgrouting,geoserver,openlayers.
I'm following the FOSS4G 2007-victoria workshop. As the workshop using the
older version of PostgreSQL, PostGIS, and pgROuting so I also installed
those version on my computer (I'm using windows).
I've been so many errors and now I got this error:
*Notice*: Undefined index: startpoint in
*C:\xampp\htdocs\rute\old15\js\ax_routing.php* on line *14*

*Notice*: Undefined offset: 1 in
*C:\xampp\htdocs\rute\old15\js\ax_routing.php* on line *15*

What's wrong with the code? I'm using my own data it's from shapefiles and
I imported to the PostgreSQL using shp loader. I can make sure that the
data is queryable using both dijkstra or A-star algorithm (I tried it on
QGIS and pgAdmin).

Please help me, anyone who ever had the same problem with me? I also tried
the latest workshop but the route can't showed up too. It's been a month
and I can't figure out what's the exact wrong, I didn't build the system
for profit, it's purely for academic purposes.

Best regards
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/pgrouting-users/attachments/20140212/51c473d3/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ax_routing.php
Type: application/x-httpd-php
Size: 4329 bytes
Desc: not available
URL: <http://lists.osgeo.org/pipermail/pgrouting-users/attachments/20140212/51c473d3/attachment-0001.php>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: peta-geos3.js
Type: application/x-javascript
Size: 7436 bytes
Desc: not available
URL: <http://lists.osgeo.org/pipermail/pgrouting-users/attachments/20140212/51c473d3/attachment-0001.js>

More information about the Pgrouting-users mailing list