[postgis-devel] crash (somehow) resolved

Michael Fuhr mike at fuhr.org
Sun Nov 13 16:57:46 PST 2005

On Sat, Nov 12, 2005 at 08:25:45PM +0100, strk at refractions.net wrote:
> On Fri, Nov 11, 2005 at 01:37:58PM -0700, Michael Fuhr wrote:
> > I have a Solaris 9/sparc box; I could probably do some testing this
> > weekend.
> Thank you. 

I ran a couple of tests under the following setup:

PostgreSQL 8.1.0 on sparc-sun-solaris2.9, compiled by GCC gcc (GCC) 3.4.2
POSTGIS="1.0.5CVS" GEOS="2.1.4" PROJ="Rel. 4.4.9, 29 Oct 2004" USE_STATS DBPROC="0.3.0" RELPROC="0.3.0"

The following query caused a bus error in 1.0.4 but worked in 1.0.5CVS:

select geomfromtext('POINT(0 0 0)');

The following query caused a bus error in both versions (stack
trace from 1.0.5CVS shown):

select collect(geom) from (select geomfromtext('MULTIPOINT(0 0)') as geom) as s;

#0  0xfed11f10 in LWGEOM_collect_garray (fcinfo=0xffbfe288) at lwgeom_functions_basic.c:1953
#1  0x0011e088 in finalize_aggregate (aggstate=0x3d08a8, peraggstate=0x3d10a8,
    pergroupstate=0x3d1138, resultVal=0x3d1078, resultIsNull=0x3d1090 "") at nodeAgg.c:559
#2  0x0011e294 in ExecAgg (node=0x3d08a8) at nodeAgg.c:830

Let me know if you'd like me to run some other queries, or if I
should re-run these queries after you change something.

Michael Fuhr

More information about the postgis-devel mailing list