[postgis-devel] 1.0.5

strk at refractions.net strk at refractions.net
Thu Nov 24 10:30:35 PST 2005

On Thu, Nov 24, 2005 at 07:55:33PM +0200, alex bodnaru wrote:
> hi strk,
> i would rename the executable to shp2pgsql_correct, and supply a script
> called shp2pgsql, to call the executable and return failure.
> and advise upgrading scripts.
> but sincerely, i believe no one relyied on the wrong code, so that
> documenting might be enough.

I think you're right about nobody using it, but we might have
the other problem: people willing to use it in future versions
not able to cope with old and new shp2pgsql revisions.

I was thinking about something like a SHP2PGSQL_RET1ONSUCCESS
The name is ugly, but the point is makeing applications
able to define it to get a consistent behaviour between
shp2pgql revisions:
	- old revision will not use the variable
	- new revision will use it sticking to old return codes


More information about the postgis-devel mailing list