[postgis-devel] Several problems with shapeloader GUI

Nicklas Avén nicklas.aven at jordogskog.no
Sun Dec 27 15:22:03 PST 2009

Hallo Mark  My results was from the experimental builds. I have never succeded to compile with GTK and libxml2. I have tried now but I get an error like this:lwgeom_functions_basic.c: In function `postgis_libxml_version':
lwgeom_functions_basic.c:204: error: `POSTGIS_LIBXML2_VERSION' undeclared (first use in this function)
lwgeom_functions_basic.c:204: error: (Each undeclared identifier is reported only once
lwgeom_functions_basic.c:204: error: for each function it appears in.)
make[1]: *** [lwgeom_functions_basic.o] Error 1
make[1]: Leaving directory `/c/utv/src/pg15/postgis'
make: *** [postgis] Error 2
I don't really get where it should get the POSTGIS_LIBXML2_VERSION from. Doxygen says it should get it from sqldefines.h but in changeset 4885 this is added in configure.acPOSTGIS_LIBXML2_VERSION=`$XML2CONFIG --version  What am I missing? Nicklas

2009-12-27 Mark Cave-Ayland wrote:

Nicklas Avén wrote:
>> When I tried as standalone it worked very good. The only thing that 
>> seems unstable in standalone is that when first file is loaded the shape 
>> file filter doesn't work when I open the file dialog for the next file.
>> I haven't done those tests very thoroughly so I can have missunderstood 
>> something, but this was what I got.
>> /Nicklas
>Hi Nicklas,
>I've found a problem with initialising GUI defaults which I have 
>corrected in SVN. Please can you try again and see if it makes a difference?
>Mark Cave-Ayland - Senior Technical Architect
>PostgreSQL - PostGIS
>Sirius Corporation plc - control through freedom
>t: +44 870 608 0063
>Sirius Labs: http://www.siriusit.co.uk/labs
>postgis-devel mailing list
>postgis-devel at postgis.refractions.net
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/postgis-devel/attachments/20091228/608a617d/attachment.html>

More information about the postgis-devel mailing list