[postgis-devel] install-sh in svn?

Greg Troxel gdt at ir.bbn.com
Tue Feb 7 12:03:38 PST 2012

Sandro Santilli <strk at keybit.net> writes:

> On Tue, Feb 07, 2012 at 10:19:56AM -0800, Chris Hodgson wrote:
>> On 12-02-07 02:02 AM, Sandro Santilli wrote:
>> >On Tue, Feb 07, 2012 at 09:47:10AM +0000, Mark Cave-Ayland wrote:
>> >>On 07/02/12 09:43, Sandro Santilli wrote:
>> >>
>> >>>I agree, but it looks like Hudson is having problems with that:
>> >>>http://office.refractions.net:1500/job/PostGIS-trunk-build/3896/console
>> >>>
>> >>>A problem with libtool 1.5.22 ?
>> >>I believe that install-sh comes from automake rather than libtool
>> >>(see automake --help).
>> >Yep, automake -a can copy it over, but also libtoolize:
>> >
>> >libtoolize --help | grep install
>> >
>> >But only from libtool version 2 onward.
>> >
>> >Automake does it at least as of version 1.10.1 (debian lenny,
>> >which is _former_ debian stable).
>> >
>> The box that hudson is running on is RHEL5-based (CentOS 5) ...
>> libtool 1.5.22, automake-1.9.6 ... yes this is ancient... if it is
>> only hudson that that is is holding us back, I *could* upgrade...
> I think it is nice to still support old systems.

To some extent, that makes sense, but it seems that RHEL/Centos is
amazingly trailing edge and the only system that comes up like this.  On
all other systems people seem expected to install semi-modern versions
of prerequisites.

automake 1.9.6 was released on 2005-07-10 (well, mod date in download dir).
automake 1.10 was released on 2006-10-15.
automake 1.10.1 was released on 2008-01-12.

So running 1.9.6 means software that is either 5.25 or 4 years out of

I can understand people not wanting to upgrade every 3 months and be
trendy, but it's hard to believe there is continuing maintenance for
security bugs, etc. on automake 1.9 and software of a similar vintage.

What I don't understand is the notion that people with systems that
contain ancient versions of everything, including automake (which isn't
needed when building from a release tarball, I'd assume) can't just be
told: first install automake in some prefix, and use it to build
postgis.  After all, we are talking about the people with the
beyond-crufty automake building postgis from svn.  (And how do those
people get a supported version of postgresql to start with?)

Put a snarkier way, why aren't those RHEL5 people satisfied with postgis
1.2.1 from 2007?  What are they really trying to do?  Perhaps someone in
this situation could explain - I'm not trying to be nasty, but I really
don't get it.

That said, I am in favor of avoiding requiring new versions when it
doesn't hurt.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 194 bytes
Desc: not available
URL: <http://lists.osgeo.org/pipermail/postgis-devel/attachments/20120207/509101a9/attachment.sig>

More information about the postgis-devel mailing list