[postgis-devel] Geography regression? SRID support back to only 4326

Paragon Corporation lr at pcorp.us
Sat Sep 27 17:57:45 PDT 2014


Okay figured out what is going on and ticketed it.

It's not a regression bug but shall I say an incomplete implementation.

I guess while I stumpled across it in regression tests, I never thought to
create a typmoded geography with it
and the typmod won't allow it.

Ticketed it:



-----Original Message-----
From: Paul Ramsey [mailto:pramsey at cleverelephant.ca] 
Sent: Saturday, September 27, 2014 3:31 PM
To: PostGIS Development Discussion; Paragon Corporation
Subject: Re: [postgis-devel] Geography regression? SRID support back to only

It’s not your imagination, I could swear I had that functionality added too.
So I don’t know quite what happened.


On September 27, 2014 at 11:45:52 AM, Paragon Corporation (lr at pcorp.us)
> Was it my imagination or were we able use any long lat spatial ref sys 
> in PostGIS 2.1. I could have sworn I had tried this in 2.1.1 or 2.1.0
> CREATE TABLE test(gid serial,geog geography(multilinestring,4269));
> And I was able to:
> But now even in 2.2.0 and on my 2.1.2 instance I get this error:
> ERROR: Currently, only 4326 is accepted as an SRID for GEOGRAPHY
> I recall it worked but if I used a non-lon-lat srid, I would get error 
> -- only degree spatial ref sys is supported
> Thanks,
> Regina
> _______________________________________________
> postgis-devel mailing list
> postgis-devel at lists.osgeo.org
> http://lists.osgeo.org/cgi-bin/mailman/listinfo/postgis-devel

More information about the postgis-devel mailing list