bjorn.harrtell at gmail.com
Thu Oct 5 04:40:49 PDT 2017
Had a short talk with Sandro about it and we agreed that a shorter name
would be nice.
Our suggestion is _mu (as in mutate).
Not sure on the cost/benefits for applying this in a API breaking way
1. _rw -> _mu (doesn't seem to dangerous?)
2. existing mutating functions that does *not* have any postfix
(potentially dangerous but would be nice for consistency?)
I really would like consistency but uncertain on the dangers.
2017-10-04 15:38 GMT+02:00 Sandro Santilli <strk at kbt.io>:
> On Wed, Oct 04, 2017 at 06:27:21AM -0700, Paul Ramsey wrote:
> > > On Oct 4, 2017, at 12:43 AM, Sandro Santilli <strk at kbt.io> wrote:
> > > But when doing the copy internally would be faster
> > > (say when no copy would happen if there's nothing to do?)
> > > how about adding a _rw for "read-write” ?
> > I don’t understand the caveat “when doing the copy internally would be
> What I mean is that sometime there's no need to make a copy, for
> example if the requested operation is not possible, or if the function
> wants to implement a copy-on-write.
> > I’ve started on creating in_place variants, now, I’m tempted to just
> commit them
> > as they come, and since they have nice big signatures we can re-name them
> > as we wish with a simple search/replace.
> > (The patch is getting larger and larger, so the sooner I land it, the
> Sure, go ahead. I won't get mad :)
> postgis-devel mailing list
> postgis-devel at lists.osgeo.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the postgis-devel