[postgis-users] failure to load postgis.sql

Christian Spanring spanring at oir.at
Mon Dec 1 10:40:47 PST 2003

I had the same erros while loading postgis.sql into my database (on Mac 
OS 10.3.1). So I tried to re-compile postgresql and postgis, proj4 and 
geos are already there and compiled without any errors or problems.
During postgresql "LDFLAGS=-lstdc++ ./configure ..." I got a warning 
that bison is too old, so I updated it to 1.8.5.

Those are the warnings that I got during postgresql make:
pgc.c:1386: warning: label `find_rule' defined but not used
pgc.c:3367: warning: `yy_flex_realloc' defined but not used

and those from postgis make:
postgis_debug.c:310: warning: control reaches end of non-void function
postgis_geos.c:248: warning: `resize_ptrArrayType' defined but not used
cc1plus: warning: "-Wmissing-declarations" is valid for C/ObjC but not 
for C++
ld: warning multiple definitions of symbol _translate
getopt.c:115: warning: conflicting types for built-in function `strncmp'
getopt.c:602: warning: no previous prototype for `getopt'
shp2pgsql.c:569: warning: implicit declaration of function `getopt'
pgsql2shp.c:1321: warning: implicit declaration of function `getopt'

Any hints what I can try next would be very appreciated.
Thanks! Christian

strk wrote:

> byronea wrote:
>> Hello,
>> Finally have compiled postgis-0.80 for my mac running osx10.3.1 with
>> postgresql-7.4. I also have proj4 and geos compiled as well. No 
>> problems
>> there.
>> but when attempting to load postgis.sql I get the following error:
>> ERROR:  could not load library 
>> "/usr/local/pgsql/lib/libpostgis.so.0.8":
>> dyld: /usr/local/pgsql/bin/postmaster Undefined symbols:
>> __ZNSs20_S_empty_rep_storageE
>> __ZNSs4_Rep11_S_max_sizeE
>> __ZNSs4_Rep11_S_terminalE
>> __ZNSt24__default_alloc_templateILb1ELi0EE12_S_force_newE
>> __ZNSt24__default_alloc_templateILb1ELi0EE12_S_free_listE
>> __ZNSt24__default_alloc_templateILb1ELi0EE22_S_node_allocator_lockE
>> __ZTIPv
>> __ZTVN10__cxxabiv117__class_type_infoE
>> __ZTVN10__cxxabiv119__pointer_type_infoE
>> __ZTVN10__cxxabiv120__si_class_type_infoE
>> __ZTVN10__cxxabiv121__vmi_class_type_infoE
>> ___cxa_pure_virtual
>> ___gxx_personality_v0
> All these symbols are likely defined in the standard C++ library.
> There is probably a missed link against stdc++.
> Have you tried re-compiling postgresql forcing libstdc++ linkage ?
> --strk;

More information about the postgis-users mailing list