[postgis-users] questions about using transform function with proj4

Nelson Tong nel_tong at hotmail.com
Wed Dec 31 16:11:20 PST 2003

  I am attempting to use the transform function that comes with postgis 0.8 
without success. The  return value that the function of  transform gives me 
is alway "null". I have checked my Makefile and made sure that the  
reporjection support is on as followed:

# Set USE_PROJ to 1 for Proj4 reprojection support
ifeq (${PROJ_DIR},)

The directory of /usr/local/bin is where the binary files of proj, nad2nad, 
cs2cs, and geod are located in my machine which is running on redhat linux 8 
with postgresql 7.2.2 .  When I ran 'make' and 'make install' for postgis, 
the installation ran without problem. After I load into a newly created 
database the functions definitons and the EPSG coordinate system definition 
with postgis.sql and spatial_ref_sys.sql, respectively, I tried to use the 
transform function to transform  coordinates of a geometry into those with a 
new coordinate system,  the values returned from the function are all 
"null". Did I set something wrong during the installation procudres of 
postgis when I enabled the reprojedtion support with proj4 library? I am 
quite sure that proj4 was installed correctly in my machine.

Thanks for reply back to my questions in advance.

N Tong

Working moms: Find helpful tips here on managing kids, home, work —  and 
yourself.   http://special.msn.com/msnbc/workingmom.armx

More information about the postgis-users mailing list