[postgis-users] Inner rings

Hartmut Tschauner tschaun at hotmail.com
Fri Jan 28 09:28:14 PST 2005

Dear listers,

In testing a PostGIS command line and query builder for free-form PostGIS
queries in ArcGIS 9 (a hopefully improved successor to PGArc, soon to be
released), I ran into some problems with holes and islands when importing
shapefiles into PostGIS (not through my own extension!). Considerable
numbers of holes disappear in the import process, islands hardly ever make
it. I imported the shapes both using the loader and via WKB. My server
version is "POSTGIS="1.0.0" GEOS="2.1.0" PROJ="Rel. 4.4.9, 29 Oct 2004"
USE_STATS DBPROC="0.1.0" RELPROC="0.1.0" in PostgreSQL 8.0 beta5 on Windows.
I have not installed RC1 or RC2 yet.

Is this a known issue/behavior? Has anyone else run into it? Does it occur
in RC1/RC2? In case someone wants to try to reproduce the problem, I attach
a Zip archive with two test shapefiles. They contain bogus shapes created
for testing my ArcGIS extension. None of the islands ever make it into
PostGIS. Nor does the triangular hole in the left square. These are only two
tiny samples; I ran into many similar problems with my "real" data.

Any comments and particularly an explanation would be appreciated.

Greetings from Seoul,

Hartmut Tschauner
Dept. of Archaeology and Art History
Seoul National University
Seoul Kwan-ak Gu, Sillimdong 56-1
ph. +82 (2) 880-9260
-------------- next part --------------
A non-text attachment was scrubbed...
Name: MultiPolygons.zip
Type: application/x-zip-compressed
Size: 2796 bytes
Desc: not available
URL: <http://lists.osgeo.org/pipermail/postgis-users/attachments/20050129/952064dd/attachment.bin>

More information about the postgis-users mailing list