[postgis-users] how to restore a singular schema within a database

Sears, Jeremy Jeremy.Sears at CCRS.NRCan.gc.ca
Thu Jan 19 14:01:54 PST 2006

Hi All,
Im wondering how to update/add a single schema to an existant database. I
have tried the following but it doesnt seem to have produced results:

>> pg_restore -c -n st pg_dump_st_20060118.pgdump

and Postgresql responds with:

>>- PostgreSQL database dump
>>SET client_encoding = 'SQL_ASCII';
>>SET check_function_bodies = false;
>>SET client_min_messages = warning;
>>-- PostgreSQL database dump complete

does this mean it worked?

I am attempting to update the a schema named 'st' in one db with a nearly
identical 'st' schema from another database. The file "pg_restore -c -n st
pg_dump_st_20060118.pgdump" was created using 'pg_dump'.

I am assuming that updating a schema is simmilar to restoring a database,
except that one specifys a specific schema that is to be restored. is this
assumption correct? Have I missed essential documentation regarding this? 


More information about the postgis-users mailing list