[postgis-users] installing postgis in Ubuntu 5.10(Breezy)

Mikael Schröder miscx at spray.se
Tue Mar 7 11:06:04 PST 2006

That was a quick response!
I get the following message when I try to install
postgresql-8.1-postgis1: Could not select all packages for the
installation or upgrade. The following packages have unresolved
dependencies. .....

  Depends: libgcc1 (>=1:4.0.2) but 1:4.0.1-4ubuntu9 will be installed
  Depends: libgeos2c2a  but it is not installable
  Depends: libstdc++6 (>=4.0.2-4) but 4.0.1-4ubuntu9 will be installed

And after that just a "close"-button
So maybe my problem really is the lack of libgeos2c2a???
/Regards Mikael

On Mar 7, 2006, at 10:30 AM, Mikael Schröder wrote:

> Hi all!
> I followed this thread and read every thing I could find on the  
> matter, but when I try to add the PostGIS 8.1 deb from within  
> Synaptic in Breezy, Synaptic complains about wrong version of  
> libstdc (4.0.1 instead of 4.0.2) and consequently libgeos2c2. How  
> can I handle this problem without compiling from source or changing  
> to next version of libstdc wich I understand to be a bit  
> bothersome. Does anyone have a different pkg for breezy?
> /Mikael
> >I appreciate your help, but I think you are working in unstable  
> with >libstdc++ 4.02 and I'm in Breezy with libstdc++4.01.  If  
> Blair can fix >his pkg then that gives Breezy users both postgresql  
> 8.1 & postgis.

What issue are you seeing?  The packages I built are only built  
against Breezy's packages.  I make all the packages I built available  
in my site, so there shouldn't be any dependencies that are not  

Also, shouldn't 4.01 and 4.02 be binary compatible?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/postgis-users/attachments/20060307/2e103240/attachment.html>

More information about the postgis-users mailing list