[postgis-users] Re: Further PostGIS / GEOS problems

Nick Black nickblack1 at gmail.com
Thu Nov 2 09:02:28 PST 2006

To follow up...

I posted a bit too quickly - I was missing a c++ compiler.  However,
I'm not in the clear yet - I still have these errors when running

checking for iconv_open in -liconv... no
checking for libiconv_open in -liconv... no

So I ran

# dpkg -S libiconv
libiconv-hook-dev: /usr/share/doc/libiconv-hook-dev/changelog.Debian.gz
libiconv-hook-dev: /usr/share/doc/libiconv-hook-dev/changelog.gz
libiconv-hook1: /usr/lib/libiconv_hook.so.1
libiconv-hook1: /usr/share/doc/libiconv-hook1/changelog.gz
libiconv-hook-dev: /usr/share/doc/libiconv-hook-dev/copyright
libiconv-hook1: /usr/share/doc/libiconv-hook1/changelog.Debian.gz
libiconv-hook-dev: /usr/share/doc/libiconv-hook-dev
libiconv-hook-dev: /usr/lib/libiconv_hook.so
libiconv-hook1: /usr/share/doc/libiconv-hook1
libiconv-hook1: /usr/lib/libiconv_hook.so.1.0.0
libiconv-hook1: /usr/share/doc/libiconv-hook1/copyright
libiconv-hook1: /usr/lib/libiconv_hook.a

and I have all the libraries isntalled, so now I am at a bit of a dead
end.  If I run make and make install, there are no explicit error
messages in the terminal, but when I log into postgres and run:

# SELECT postgis_full_version();
ERROR:  could not access file "$libdir/liblwgeom.so.1.1": No such file
or directory
CONTEXT:  SQL statement "SELECT  postgis_lib_version()"
PL/pgSQL function "postgis_full_version" line 11 at select into variables

>From the end of configure:

   PROJ: prefix=/usr libdir=/usr/lib


locate liblwgeom.so.1.1

So I am wondering if the build was successfull?

The output of configure is posted here:


Thanks again,


On 11/2/06, Nick Black <nickblack1 at gmail.com> wrote:
> Hello,
> Thanks to some help from this list and #postgis, I have diagnosed the
> problem with GEOS that I described earlier.
> So now I am trying to compile postgis, with this configure option:
>  ./configure --prefix=/usr --with-pgsql=/usr/bin/pg_config
> --with-geos=/usr/bin/geos-config --with-proj=/usr
> Which give this error:
> checking for gcc... gcc
> checking for C compiler default output file name... a.out
> checking whether the C compiler works... yes
> checking whether we are cross compiling... no
> checking for suffix of executables...
> checking for suffix of object files... o
> checking whether we are using the GNU C compiler... yes
> checking whether gcc accepts -g... yes
> checking for gcc option to accept ANSI C... none needed
> checking for g++... no
> checking for c++... no
> checking for gpp... no
> checking for aCC... no
> checking for CC... no
> checking for cxx... no
> checking for cc++... no
> checking for cl... no
> checking for FCC... no
> checking for KCC... no
> checking for RCC... no
> checking for xlC_r... no
> checking for xlC... no
> checking whether we are using the GNU C++ compiler... no
> checking whether g++ accepts -g... no
> checking whether ln -s works... yes
> checking for iconv_open in -liconv... no
> checking for libiconv_open in -liconv... no
> checking for iconv_open in -lc... yes
> checking how to run the C preprocessor... gcc -E
> checking for egrep... grep -E
> checking for ANSI C header files... yes
> checking for sys/types.h... yes
> checking for sys/stat.h... yes
> checking for stdlib.h... yes
> checking for string.h... yes
> checking for memory.h... yes
> checking for strings.h... yes
> checking for inttypes.h... yes
> checking for stdint.h... yes
> checking for unistd.h... yes
> checking iconv.h usability... yes
> checking iconv.h presence... yes
> checking for iconv.h... yes
> checking build system type... i686-pc-linux-gnu
> checking host system type... i686-pc-linux-gnu
> checking for geos-config... /usr/bin/geos-config
> Usage: geos-config [OPTIONS]
> Options:
>      [--prefix]
>      [--version]
>      [--libs]
>      [--cflags]
>      [--includes]
>      [--jtsport]
> checking for proj... /usr/bin/proj
> checking for flex... /usr/bin/flex
> checking for dllwrap... no
> checking for dlltool... no
> checking for bison... bison -y
> checking for perl... /usr/bin/perl
> checking for xsltproc... /usr/bin/xsltproc
> checking for pdfxmltex... no
> checking for db2pdf... no
> checking for jw... no
> checking which template to use... linux
> configure: creating ./config.status
> config.status: creating Makefile.config
> config.status: creating config.h
> config.status: config.h is unchanged
>  -------------------------------------------------------
>  HOST_OS: linux-gnu
>    PGSQL: /usr/bin/pg_config
>     GEOS: /usr/bin/geos-config
>           (ldflags: )
>     PROJ: prefix=/usr libdir=/usr/lib
>    ICONV: 1
>  PORTNAME: linux
>    PREFIX: /usr
>   EPREFIX: ${prefix}
>       DOC: ${prefix}/share/doc
>      DATA: ${prefix}/share
>       MAN: ${prefix}/man
>       BIN: ${exec_prefix}/bin
>       EXT: ${exec_prefix}/lib (${exec_prefix}/lib)
>  -------------------------------------------------------
> Seems that configure cant find g++ etc - which seems strange, as I can
> compile other sources without problems.
> I am running Ubuntu 6.06,  psql 8.1.4
> Thanks again,
> Nick

More information about the postgis-users mailing list