[postgis-users] Query slow down, never completes

Andreas Forø Tollefsen andreasft at gmail.com
Tue Oct 11 08:12:24 PDT 2011

Hi Sandro,

What i find strange is that it stops processing at different years on my
desktop and my laptop. While my desktop stops processing at 1980, my slower
laptop goes on to 1991 before halting.
I also tried with different postgresql.conf shared_buffers settings without
making any difference.
Therefore it is hard to reproduce this for a single year. I can easily
process 1980 or 1991 if just running the script for that year.

2011/10/11 Sandro Santilli <strk at keybit.net>

> On Tue, Oct 11, 2011 at 02:25:20PM +0200, Andreas Forø Tollefsen wrote:
> > I also tried to close the db1 connection for each year in the loop, and
> > reopen the connection for the next year in the loop. Same problem.
> > I have tried both with insert into ... select .. and select into annual
> > tables and the put them together. Same problem.
> Then I guess the problem is with the specific data you encounter
> at the given year. Can you reproduce the hangup in the query for
> a single year ? Keep an eye on memory use and CPU utilization.
> --strk;
>  ()   Free GIS & Flash consultant/developer
>  /\   http://strk.keybit.net/services.html
> _______________________________________________
> postgis-users mailing list
> postgis-users at postgis.refractions.net
> http://postgis.refractions.net/mailman/listinfo/postgis-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/postgis-users/attachments/20111011/c46e1e3e/attachment.html>

More information about the postgis-users mailing list