[postgis-users] Voronoi in PostGIS

Puneet Kishor punk.kish at gmail.com
Tue Mar 13 18:38:55 PDT 2012

On Mar 13, 2012, at 8:22 PM, Dheeraj Chand wrote:

> Thanks!
> 1. Altering $PKG_CONFIG to just ../bin worked!
> 2. Fixed the issue with the R path.

I am out of my depth here, and besides, I am only guessing what is going on with your computer. Nevertheless, it seems you once again tried to `make install` without sudo, and that failed.

> ..
> GENESISARK:plr dheerajchand$ USE_PGXS=1 make install
> /bin/sh /usr/local/pgsql-9.1/lib/pgxs/src/makefiles/../../config/install-sh -c -d '/usr/local/pgsql-9.1/lib'
> /bin/sh /usr/local/pgsql-9.1/lib/pgxs/src/makefiles/../../config/install-sh -c -d '/usr/local/pgsql-9.1/share/extension'
> /bin/sh /usr/local/pgsql-9.1/lib/pgxs/src/makefiles/../../config/install-sh -c -d '/usr/local/pgsql-9.1/share/doc/extension'
> mkdir: /usr/local/pgsql-9.1/share/doc/extension: Permission denied
> make: *** [installdirs] Error 1

After that you tried it again with `sudo`

> GENESISARK:plr dheerajchand$ sudo USE_PGXS=1 make install
> Password:
> make: *** No rule to make target `install'.  Stop.

Dunno what to suggest. Perhaps do a complete `make clean` and do everything again making sure, but I am just guessing. Hopefully, someone else knows what is going on.

Puneet Kishor

More information about the postgis-users mailing list