[postgis-users] [postgis-devel] VOTE: Drop PostgreSQL 9.0 support at PostGIS 2.2

Paragon Corporation lr at pcorp.us
Sun Jun 9 12:49:20 PDT 2013


I'm cc'ing postgis users just in case some package maintainers there or
users that might be affected.

Not sure who the various package maintainers are.  From what I have seen,
other distros only support one version of PostgreSQL for each version of
except for windows which we manage and we're thinking of dropping 9.0
installers for PostGIS 2.1 for windows before it comes out (except for
binaries) just because few seem to be using
2.0 + 9.0 on windows gathering from the bug submitted by windows users so
likely we'd be supporting a none existent or tiny user base for 2.1 (on

That said this is for 2.2 anyway (and PostGIS 2.1 is still in beta) and
PostGIS group will still be supporting 2.1 and 2.0 on 9.0 . 
Given 2.2 hasn't even been branched yet, I think this is pretty much a
non-issue since no package maintainers will be compiling against 
2.2 yest.  That's why I wanted to get this out of the way so we don't run
into starting supporting anything and then cut it off midstream while people
have already started building against it and thinking they can use it with
their version of PostgreSQL.


-----Original Message-----
From: postgis-devel-bounces at lists.osgeo.org
[mailto:postgis-devel-bounces at lists.osgeo.org] On Behalf Of Magnus Hagander
Sent: Sunday, June 09, 2013 2:29 PM
To: PostGIS Development Discussion
Subject: Re: [postgis-devel] VOTE: Drop PostgreSQL 9.0 support at PostGIS

On Sat, Jun 8, 2013 at 5:07 PM, Paragon Corporation <lr at pcorp.us> wrote:
> I think we discussed this but didn't come to an official consensus.
> Before we branch to 2.2 in the next couple fo weeks, I'd like to get 
> this out of the way.
> As I have said reasons for dropping
> 1) Too many PostgreSQL to test and if we ain't going to test it we 
> shouldn't be saying we support it.
> 2) Dropping 9.0, all versions left will support extensions which means 
> getting rid of that conditional extension check.
> 3) Raster and PostGIS have some legacy code to handle 9.0 in basic 
> postgis the knn gist operators are not supported in 9.0 In case of 
> raster, Bborie had to put in some logic for 9.0 for the way it handles 
> aggregates.
> It will also make the post-check I'm proposing a tad easier as it 
> would only do extension testing:
> http://trac.osgeo.org/postgis/ticket/2358
> Thoughts, concerns, vote

I'd suggest you check with packagers for the different distributions if this
is going to cause some issues for them. If it's going to cause a lot of
extra downstream work there, it might be better to take the pain upstream,
since it's only once.

Assuming you're still going to support he old branches, though, I don't see
any problem at all in the general idea :)

 Magnus Hagander
 Me: http://www.hagander.net/
 Work: http://www.redpill-linpro.com/
postgis-devel mailing list
postgis-devel at lists.osgeo.org

More information about the postgis-users mailing list