[postgis-users] Error with Ubuntu installation from PostgreSQL APT repository

Stephen V. Mather svm at clevelandmetroparks.com
Tue Jul 8 16:40:33 PDT 2014

Related, I started last night with a fork of vpicavet's docker/pggis as a fresh installer for PostGIS and friends for Ubuntu 14.4.  It's not fully functional yet but serves as a sign post for installs on Ubuntu.

Where would one start in doing package management for Debian / Ubuntu? Seems an ongoing issue for these flavors...


On Jul 8, 2014 6:44 PM, Matthew Baker <mattbaker at gmail.com> wrote:
Hi all,

Last year I wrote up some PostGIS installation instructions for Ubuntu based on the PostgreSQL APT repository:


These worked great for a while, but seems to have stopped working with Ubuntu 14.04.

I know there was a thread back at the end of January discussing the version of GDAL that would work with PostGIS (1.9 / 1.10) , but if nothing else, here's an update on the installation error messages:

--When running this on a fresh Ubuntu 14.04 VM - with no QGIS installed (thanks Stephen), here are the messages that I get:

After running this command:

sudo apt-get install postgresql-9.3 postgresql-9.3-postgis pgadmin3 postgresql-contrib

I get the message:

Package postgresql-9.3-postgis is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'postgresql-9.3-postgis' has no installation candidate

So I modified the install command specific to PostGIS:

sudo apt-get install postgresql-9.3 postgis pgadmin3 postgresql-contrib

Which gives the message:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 postgis : Depends: libgdal1 (>= 1.9.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

So I tried to install libgdal1 v 1.10.0 via Synaptic Package Manager, but it doesn't seem to help.

That's where I'm stuck.

Does anyone have any info either regarding this error, or if the PostgreSQL APT repo is still packaging PostGIS?

I will try this on Ubuntu 12.04.4 just for fun...

I appreciate any feedback! Thank you!!!


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/postgis-users/attachments/20140708/44cba966/attachment.html>

More information about the postgis-users mailing list