[postgis-users] broken package postgresql-9.4-postgis-2.1 for ubuntu 14.04

Andreas Laggner andreas.laggner at ti.bund.de
Tue Feb 16 02:23:12 PST 2016

Hello list,

installing this package on ubuntu 14.04 from repo "deb 
http://apt.postgresql.org/pub/repos/apt trusty-pgdg main" leads to errors.

First strange thing is, that choosing postgresql-9.4-postgis-2.1 ends up 
in installing postgresql-9.4-postgis-2.1 AND postgresql-9.4-postgis-2.2, 
ubuntu needs postgresql-9.4-postgis-2.2 as dependency for 

After install everythings seems to be ok. But it is not: shp2pgsql is 
missing! If i try to install postgis 2.2 or 2.1.8 neither from repo or 
from source i get the message "Postgresql 9.5 must be installed first".

So - right now it's not possible to install postgres 9.4 with postgis on 
ubuntu 14.04

Could you please help me?

Thanks        Andreas

Dipl. Geoökologe Andreas Laggner

Thünen-Institut für Agrarklimaschutz (AK)
Arbeitsgruppe Emissionsinventare
Johann Heinrich von Thünen-Institut (vTI),
Bundesforschungsinstitut für Ländliche Räume, Wald und Fischerei

Thünen Institute of Climate-Smart Agriculture
Johann Heinrich von Thünen Institute (vTI),
Federal Research Institute for Rural Areas, Forestry and Fisheries

Bundesallee 50
D-38116 Braunschweig

Tel.: (+49) (0)531 596 2636
Fax : (+49) (0)531 596 2645
E-mail: andreas.laggner at ti.bund.de
Homepage: http://www.ti.bund.de

More information about the postgis-users mailing list