[postgis-users] raster2pgsql

Severin Thaler sev.thaler at gmail.com
Fri Feb 19 10:47:44 PST 2016

Dear all,

i have been trying to use raster2pgsql to ingest a netcdf with multiple variables through:

raster2pgsql -s 4326 -a -C -M -t 10x10 my_netcdf my_table

but i get:

Processing 1/1: my_netcdf
ERROR: convert_raster: No bands found in raster: my_netcdf
ERROR: process_rasters: Could not process raster: my_netcdf
ERROR: Unable to process rasters

i then extracted a single variable from the netcdf through ‘ncks’ and then tried to ingest
the single variable netcdf with raster2pgsql and it worked. it also worked with another single variable,
but as soon as i tried with 2 vars it again didn’t work with the same error.

so it really seems to be that raster2pgsql can only handle a single variable is that true?

to be precise, the variables i have are:
lat(lat), lon(lon), time(time), and only one ‘real’ variable, e.g. temperature(time, lat, lon)

also, does the dimensions the variable depends on need to be in a certain order, i.e.
would e.g. temperature(time, lat, lon) not work? and are there any other possible conventions
that the netcdf has to follow in order for raster2pgsql to work, thanks.

More information about the postgis-users mailing list