[postgis-users] postgis.backend and legacy functions

Willy-Bas Loos willybas at gmail.com
Wed Feb 24 07:42:17 PST 2016


I ran into a very strange problem today. It is especially strange to me
because it was (temporarily) solved and i don't understand why.

The problem:
A dump from a (pg 9.4) database with postgis-2.1 and legacy.sql was
restored on a server that has bot postgis-2.1 and postgis-2.2 installed.
Because pg_dump uses only CRATE EXTENSION, the new database now has
postgis-2.2 but with the legacy functions from postgis-2.1

Now, i get an error when calling some functions. Other functions do work.
2016-02-24 10:28:52 CET [17136-10] postgres at telmee_oz ERROR:  attempt to
redefine parameter "postgis.backend"
2016-02-24 10:28:52 CET [17136-11] postgres at telmee_oz STATEMENT:  select
ST_area(survey.locations.the_geom) as opp
        FROM survey.locations LIMIT 1;

I didn't try out all the functions, because i was looking for a more
general pattern.
Anyway i know:
* area
not working:
* st_area
* st_xmin
* x_min

When i found that all the functions that use the postgis-1.2 binairies
belong to legacy, i tried to install the legacy.sql form postgis-2.2 in the
new database.
This resulted in a lot of 'attempt to redefine parameter "postgis.backend"'
-errors (and some newly installed functions), but after this, the problem
was gone.

This doesn't make sense to me at all. And, the database will be overwritten
with a fresh copy this weekend, which will probably recreate the problem.
Can anyone here help me find out what is(or was) happening?

Willy-Bas Loos
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/postgis-users/attachments/20160224/e46a187c/attachment.html>

More information about the postgis-users mailing list