[postgis-users] postgis.backend and legacy functions

Willy-Bas Loos willybas at gmail.com
Thu Feb 25 02:58:07 PST 2016

On Thu, Feb 25, 2016 at 9:01 AM, Sandro Santilli <strk at keybit.net> wrote:

> >  area(geometry) uses postgis-2.1
> > and st_area(geometry) uses postgis-2.2
> The best way to fix this would be to update the legacy functions
> so to have them use postgis-2.2 too.
Thanks for the Reply.
This seems to be related to https://trac.osgeo.org/postgis/ticket/2382 (in
which you, strk, seem to have been involved).
The problem occurs in an unregular fashion. I'm not yet sure about how to
create it or how to solve it, but both has happened multiple times since
The problem is that postgis errors out in most functions, because 'attempt
to redefine parameter "postgis.backend" '.
That leaves postgis in a broken state .

I have replaced the legacy functions like you suggested, which worked much
to my surprise, but did not fix the problem - at least not directly.
Yesterday i also tried to replace the legacy functions, but then i did not
work (lots of errors about postgis.backend and functions were not
replaced), and it *did* fix the problem for a while.

I will report back when i have clearer info about reproducing.
One thing that i'm looking into is setting and showing postgis.backend

Willy-Bas Loos
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/postgis-users/attachments/20160225/3e84fdb5/attachment.html>

More information about the postgis-users mailing list