[postgis-users] How to use PostGIS without being a superuser

Christopher BROWN brown at reflexe.fr
Wed Jan 11 00:52:29 PST 2017


Problem seems solved, mainly by reinstalling.  After that, just needed to
be PostgreSQL "superuser" to run CREATE EXTENSION, and after that, no other
permission problems with normal user (as long as superuser ran the CREATE
EXTENSION command with the search_path set to the target schema in the
target database).


On 10 January 2017 at 20:11, Christopher BROWN <brown at reflexe.fr> wrote:

> Hello,
> I've tried finding the solution on my own, but have been unable to
> understand (from PostGIS and PostgreSQL documentation, and from web
> searches).  Basically, no problem installing or using PostGIS with a
> superuser account (not the "postgres" user however), but can't event
> run select postgis_full_version(); in some cases as a "normal" user.
> In one case, the DBA ran the "create extension postgis" command as the
> "postgres" superuser, but although the "normal" user could create
> tables with default PostgreSQL types, impossible to create anything
> like a geometry or geography column (permissions error: type
> "geography" doesn't exist).
> Unless I've been looking in the wrong places (not impossible), the
> guides quickly run through the installation steps without going into
> detail.  I'd like to understand how to do this without resorting to
> the superuser, and without blindy running random commands from
> different forums.
> I'm using PostgreSQL 9.6.1 with PostGIS 2.3.1 from ppa repositories on
> Ubuntu 14.04 LTS.
> Thanks in advance.
> --
> Christopher
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/postgis-users/attachments/20170111/7764f13c/attachment.html>

More information about the postgis-users mailing list