[postgis-users] st_union produces different result from st_memunion

Martin Davis mtnclimb at gmail.com
Tue Jul 7 22:41:25 PDT 2020

That's interesting that ST_SnapToGrid doesn't help for the full dataset -
but not totally surprising, since it's a pretty blunt instrument.

I'd like to try out the larger dataset.  That free download website seems
to have a bunch of unpleasant strings attached though - is there any other
way you can make the data available?

If you are able to run Java, by all means try OverlayNG.  Happy to provide
advice on how to run it if needed.

cheers - Martin

On Tue, Jul 7, 2020 at 8:10 PM Jonathan Schultz <jonathan at schultz.la> wrote:

> Thank you for the prompt feedback.
> As you suggested I tried using ST_SnapToGrid and that worked very well
> even with a very fine grid - st_snaptogrid(geometry,0.000000000001).
> However when it came to a collection of lines more useful for real work
> (13540 records compared with 6 in the minimal dataset) I found that
> snapping even to a grid so coarse as to render the data useless -
> st_snaptogrid(geometry,0.01) - still produced an incorrect result.
> Here is the dump of my larger dataset:
> https://anonfiles.com/rdYcG1Edo2/dbca_dump_116_35_117_34_sql
> I'll have a go myself with OverlayNG.
> And I will file a PostGIS issue depending on the conclusions from this
> discussion.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/postgis-users/attachments/20200707/3e4c39c0/attachment.html>

More information about the postgis-users mailing list