[postgis-users] Permission denied when using ST_EstimatedExtend

Oliver Morris Oliver.Morris at halliburton.com
Tue Sep 22 04:23:15 PDT 2020

Hi, I recently can across this issue and welcome any suggestions as to what the cause maybe:

If I run:
select ST_EstimatedExtent('primedata', 'ann_ocean_V_v_seas_max', 'the_geom');
I get:
ERROR: permission denied for schema primedata SQL state: 42501

If I run:
select ST_Extent(the_geom) from primedata."ann_ocean_V_v_seas_max" limit 100;
It get the returned result: "BOX(-180 -90,180 90)"

I ran these in the same query editor window.

Currently I am using: "3.0 USE_GEOS=1 USE_PROJ=1 USE_STATS=1"

Many thanks for any suggestions you may have.

Thank you


This e-mail, including any attached files, may contain confidential and privileged information for the sole use of the intended recipient. Any review, use, distribution, or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive information for the intended recipient), please contact the sender by reply e-mail and delete all copies of this message.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/postgis-users/attachments/20200922/b8917b37/attachment.html>

More information about the postgis-users mailing list