[postgis-users] Error: "Precision reduction requires GEOS-3.9 or higher"

Marco Boeringa marco at boeringa.demon.nl
Sun Apr 18 05:42:14 PDT 2021

Hi Sandro,

Thanks for the answer, but this just raises a question, why was the 
official PostGIS 3.1.1 as available in the

"http://apt.postgresql.org/pub/repos/apt/focal-pgdg main"

repository, not compiled with GEOS 3.9.0, if it is supposed to be able 
to take advantage of new GEOS 3.9.0 functionality?

Of course, I understand GEOS 3.9.0 was not available at the time Ubuntu 
Focal 20.04 LTS was launched, but neither was PostGIS 3.1.1. Yet PostGIS 
was updated to 3.1.1 on Focal through the PostgreSQL repository for Focal?

Or would a PostGIS 3.1.1 compiled against GEOS 3.9.0 cause issues on a 
default Ubuntu Focal install with just GEOS 3.8.0, due to incompatibilities?

Sorry if I am rambling and this doesn't make sense. Although I am slowly 
getting to know Linux and Ubuntu, some of this packaging and repository 
stuff is still a bit of a mystery to me...


Op 18-4-2021 om 14:21 schreef Sandro Santilli:
> On Sat, Apr 17, 2021 at 09:01:33AM +0200, Marco Boeringa wrote:
>> Before I upgraded libgeos from the ubuntugis repository,
>> "PostGIS_Full_Version()" showed GEOS 3.8.0.
>> So how do I potentially solve this? Or is this upgrade of GEOS only possible
>> by compiling PostGIS from source yourself (which I would definitely like to
>> avoid)?
> No way out of compiling PostGIS from source.
> It could be done by you or by some third party who could have made
> a package for your OS available.
> --strk;
> _______________________________________________
> postgis-users mailing list
> postgis-users at lists.osgeo.org
> https://lists.osgeo.org/mailman/listinfo/postgis-users

More information about the postgis-users mailing list