PROJ version mismatch in PostGIS version output?

Regina Obe lr at pcorp.us
Fri Oct 16 09:08:29 PDT 2026


> Hi,
> 
> I recently upgraded my Ubuntu VM from 24.04 LTS to 26.04 LTS.
> 
> After re-enabling the PostgreSQL apt repository for the new 26.04 Ubuntu
> version and installing PostgreSQL from there, and re-running one of my Python
> tools, I noticed the PROJ version is listed as 9.8.1, but there is a second
> message I don't remember seeing before about "compiled against PROJ
> 9.7.1". Is this version mis-match of any concern, or inconsequential and can be
> ignored?
> 
> Marco
> 
> POSTGIS="3.6.4 94d984b" [EXTENSION] PGSQL="180"
> GEOS="3.14.1-CAPI-1.20.5" SFCGAL="SFCGAL 2.2.0, CGAL 6.0.1, BOOST
> 1.88.0" PROJ="9.8.1 NETWORK_ENABLED=OFF
> URL_ENDPOINT=https://cdn.proj.org
> USER_WRITABLE_DIRECTORY=/tmp/proj
> DATABASE_PATH=/usr/share/proj/proj.db" (compiled against PROJ 9.7.1)
> LIBXML="2.15.2" LIBJSON="0.18" LIBPROTOBUF="1.5.1" WAGYU="0.5.0
> (Internal)"


It's extra information we added to track issues with possible mismatches.  So should it be entirely of no concern, I would say no, but as long as the versions don't deviate too much, it shouldn't be a major concern. 

The main concerns arise when Proj make structural changes to the proj.db e.g adding new fields etc, which we've run into in the past when e.g. you get proj from Ubuntun GIS and it deviates from what you are getting with apt.  You just need to make sure whatever PROJ version you are running with (9.8.1) matches your database path.

PostGIS will never expose newer PostGIS functions for proj not available in the PROJ it was compiled against.  I don't think we've made any new functions available under 9.8.1 that we didn't expose under 9.7.1 so that is probably not a concern either.

I know that apt.postgresql.org repo recently changed so they are not getting their dependencies from your Ubuntu package version.
I think the main reason for that was to be able to ship PostGIS with newer versions of GEOS even if you are on an old Ubuntu version so that might be why you are starting to see this message.
In the old days they would have compiled against the PROJ shipped with 26.04, which I presume in this case is 9.8.1.
It might be shipping a PROJ 9.7.1 as well.  Might be worth asking on apt.postgresql.org mailing list if you start to see issues with this.



More information about the postgis-users mailing list