[Qgis-developer] QGIS crash on Mac OS X -- 0.8 release branch

Tom Elwertowski telwertowski at comcast.net
Sat May 12 00:43:50 EDT 2007

Gary Sherman wrote:
> I've tried the complete rebuild several times, changing minor things. 
> Still no luck. Since my build failed on Tim's system, it seems like it's 
> something particular to my setup. But I'm not doing anything different 
> than previous builds, except this is on a new machine (intel).

I discovered how to reproduce your crash in 
QgsOgrProvider::loadFields(). I did it by building with frameworks 
rather then traditional libraries.

In my case, I have dependent packages present in both 
/Library/Frameworks and /usr/local. For at least some "#include <...>" 
statements, the build is reading from /usr/local instead of 
/Library/Frameworks. If I rename the header in /usr/local, it then uses 
the one in /Library/Frameworks. If I introduce an error into the header 
in /usr/local, the build fails.

I checked a handful of cmake generated files and the paths are what I 
expect. Plenty of -I/Library/Frameworks/xxx.framework/Headers and no 
-I/usr/local/include so I am baffled as to why I end up with an 
inconsistent build.

This makes me wonder if you have some non-framework headers which are 
being picked up and producing an inconsistent build.


More information about the Qgis-developer mailing list