[Qgis-developer] Ubuntu 8.10 and QGIS 0.11

Alex Mandel tech_dev at wildintellect.com
Sun Nov 2 19:49:35 EST 2008

Alex Mandel wrote:
> Well, it appears to be an issue on only some machines possibly related
> to video card drivers and X11 not necessarily qt.
> Both 0.11 and 1.0 kore work on a fresh Ubuntu install (tested in virtual
> box) so kde libs are not the solution.
> I have an nvidia gforce 8600gm, and tried both the nv and nvidia(177)
> drivers, haven't tried plain vga drivers yet.
> Carson: what video card do you have?
> Any ideas,
> Alex

>       #10 0xb7a1b3a7 in ?? () from /usr/lib/libQtGui.so.4
>   14.
>       #11 0xb7a19ea1 in QInputContextFactory::create () from
> /usr/lib/libQtGui.so.4
>   15.
>       #12 0xb3ff5c40 in ?? ()
>   16.
>          from /usr/lib/qt4/plugins/inputmethods/libqimsw-multi.so
>   17.
>       #13 0xb3ff63f6 in ?? ()
>   18.
>          from /usr/lib/qt4/plugins/inputmethods/libqimsw-multi.so

I ran another backtrace on a custom compiled qgis. The last line was not
the same making me think X might not be entirely repsonsible but these
?? lines occurred with libqt stuff. When I hit q gdb actually says
quiting from /usr/lib/qt4/plugins/inputmethods

Which brings up 2 clues:
1. my custom build does not appear to be using my custom Qt compile, how
do I force that in the ccmake step. I changed the qt_make line to point
to the right one.
2. libqimsw-multi.so seems to have something to do with it, possibly
solved by fixing #1

If it is something in X11 what's the commonality between the 3 machines
where it doesn't work, I have nvidia, Carson Intel and Tim ?
How would I attempt to fix/solve where the problem is?


More information about the Qgis-developer mailing list