[Qgis-developer] crash on startup

Pedro Venâncio pedrongvenancio at yahoo.com
Sat May 12 16:41:24 PDT 2012


I'm also experiencing this problem after the last Debian (Wheezy) upgrade.

I tried this solution, creating a link, but still giving me this error:

   pedro at debian-amilo:~$ qgis
   Warning: loading of qgis translation failed [/usr/share/qgis/i18n//qgis_en_US]
   Warning: loading of qt translation failed [/usr/share/qt4/translations/qt_en_US]
   qgis.bin: /tmp/buildd/sip4-4.13.2/siplib/siplib.c:10938: sipEnumType_alloc: Assertiva `(((currentType)->td_flags & 0x0007) == 0x0003)' falhou.

Here is the link that I created:

   pedro at debian-amilo:~$ ls -lh /usr/lib/x86_64-linux-gnu/libQtWebKit.so 
   lrwxrwxrwx 1 root root 23 Mai 13 00:11 /usr/lib/x86_64-linux-gnu/libQtWebKit.so -> /usr/lib/libQtWebKit.so

What am I doing wrong?

I've also tried to upgrade the libqtwebkit-dev and libqtwebkit4 with the sid repository, but QGIS continues to crash.


Best regards,
Pedro Venâncio

----- Original Message -----
From: Paolo Cavallini 

Hash: SHA1

Il 12/05/2012 08:25, Werner Macho ha scritto:
> I think it should be reportet upstream to debian package maintainer ..
> for now you can solve it by setting a link from
> /usr/lib/libQtWebKit.so to
> /usr/lib/x86_64-linux-gnu/
> lrssvt pointed out this solution yesterday on IRC

Thanks a lot Werner (and lrssvt), that made it.
I'm going to report the issue upstream.
All the best.
- -- 
Paolo Cavallini - Faunalia
Full contact details at www.faunalia.eu/pc

More information about the Qgis-developer mailing list