[Qgis-developer] Preventing plugin conflicts at 2.0

Borys Jurgiel lists at borysjurgiel.pl
Thu Apr 11 08:16:45 PDT 2013

Dnia czwartek, 11 kwietnia 2013 o 17:39:38 Gary Sherman napisał(a):
> Greetings developers,
> I think we should consider a way to flag existing plugins that are not
> compatible with the new 2.0 api. This will improve user experience by
> preventing install of plugins that do not work with the users current QGIS
> version.
> Ideally all plugins would be converted to work with both 1.8 and 2.0, but
> this either won't happen completely or will take an unknown amount of time.
> This situation has already happened to those living on the bleeding edge
> (using 1.9 in production):
> http://gis.stackexchange.com/questions/57718/qgis-trace-tool-error/57724#57
> 724
> One way to do this is to implement a "QGIS maximum version" entry in the
> plugins metadata (or __init__.py). Alternatively there may be a way to do
> this with the plugin repository app, however I'm not familiar enough with
> its implementation to suggest how that could be done.
> Please provide feedback...

The plugin compatibility and installer refactoring is my major task for the 
HF. We'll discuss a target architecture for 2.x as soon as Alessandro and Alex 
are here, then let you know our plans. In the worst case, we manage to 
implement some basic compatibility updates and only start a deeper refactoring 
for 2.1. In the best case (if we manage to fully implement something bigger) 
maybe we even ask for a feature freeze break. Tomorrow I'll be able to say 

Btw. Actually the plugin installer already supports the qgis_maximum_version 
at least since QGIS 1.0, only the new repository probably doesn't (yet). There 
is also a small feature in the installer that was useful when we were between 
0.x and 1.0. In QGIS 1.x, the installer only accepts plugins with either:
- qgis_minimum_version >= 1.0
- qgis_minimum_version < 1.0 AND qgis_maximum_version >= 1.0
So if qgis_minimum_version is 0.x, it assumes that the plugin is incompatible 
with 1.x unless the qgis_maximum_version is set. We can either do the same now 
or assume the plugin is compatible unless qgis_maximum_version is set to < 

More information about the Qgis-developer mailing list