[Qgis-developer] Qgis sip problems - virtualenv to blame

Barry Rowlingson b.rowlingson at lancaster.ac.uk
Sun Jan 5 04:27:28 PST 2014

Hi all

 I've just spent an hour install qgis on a new Mint linux (saucy) box.
Here is the tale...

 I was using the qgis repo (because there's no ubuntugis for saucy at
the moment) and getting very weird behaviour. Installing the
python-qgis package removed the qgis package. And vice versa. I
eventually removed everything python, sip, gdal and qgis related and
eventually it all installed. Great. I think that problem was I did
have the ubuntugis repo in there at one point, and it may have been
getting incompatible gdal bits from somewhere.

 But then I ran it, and qgis python couldn't find sip so no python support.

 Python from the command line couldn't "import sip". I checked the
package dependencies - it was all there....

 Then I noticed I was running from a virtualenv....

 Tried from a fresh shell, and all was working - qgis and python in
perfect harmony. I can now get mapping!

 So I send this as a reminder that if people are having weird python
problems, check they aren't running from a virtualenv.


More information about the Qgis-developer mailing list